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Preface

This preface contains these topics:

■ Intended Audience

■ Documentation Accessibility

■ Organization

■ Related Documentation

■ Conventions
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Intended Audience
Oracle Application Server InterConnect is intended for those who perform the

following tasks:

■ install applications

■ maintain applications

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation

accessible, with good usability, to the disabled community. To that end, our

documentation includes features that make information available to users of

assistive technology. This documentation is available in HTML format, and contains

markup to facilitate access by the disabled community. Standards will continue to

evolve over time, and Oracle Corporation is actively engaged with other

market-leading technology vendors to address technical obstacles so that our

documentation can be accessible to all of our customers. For additional information,

visit the Oracle Accessibility Program Web site at

http://www.oracle.com/accessibility/

Accessibility of Code Examples in Documentation JAWS, a Windows screen

reader, may not always correctly read the code examples in this document. The

conventions for writing code require that closing braces should appear on an

otherwise empty line; however, JAWS may not always read a line of text that

consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation This

documentation may contain links to Web sites of other companies or organizations

that Oracle Corporation does not own or control. Oracle Corporation neither

evaluates nor makes any representations regarding the accessibility of these Web

sites.

Organization
This document contains:

Chapter 1, "Introduction to the Configuration Editor"
This chapter describes the Configuration Editor.
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Chapter 2, "Using the Configuration Editor"
This chapter describes using the Configuration Editor.

Related Documentation
For more information, see these Oracle resources:

■ Oracle Application Server InterConnect User’s Guide

■ Oracle Application Server InterConnect Installation Guide

Printed documentation is available for sale in the Oracle Store at

http://oraclestore.oracle.com/

To download free release notes, installation documentation, white papers, or other

collateral, please visit the Oracle Technology Network (OTN). You must register

online before using OTN; registration is free and can be done at

http://otn.oracle.com/membership/

If you already have a username and password for OTN, then you can go directly to

the documentation section of the OTN Web site at

http://otn.oracle.com/documentation/

Conventions
This section describes the conventions used in the text and code examples of this

documentation set. It describes:

■ Conventions in Text

■ Conventions in Code Examples

■ Conventions for Microsoft Windows Operating Systems

Conventions in Text
We use various conventions in text to help you more quickly identify special terms.

The following table describes those conventions and provides examples of their use.



x

Conventions in Code Examples
Code examples illustrate SQL, PL/SQL, SQL*Plus, or other command-line

statements. They are displayed in a monospace (fixed-width) font and separated

from normal text as shown in this example:

Convention Meaning Example

Bold Bold typeface indicates terms that are
defined in the text or terms that appear in
a glossary, or both.

When you specify this clause, you create an
index-organized table.

Italics Italic typeface indicates book titles or
emphasis.

Oracle9i Database Concepts

Ensure that the recovery catalog and target
database do not reside on the same disk.

UPPERCASE
monospace
(fixed-width)
font

Uppercase monospace typeface indicates
elements supplied by the system. Such
elements include parameters, privileges,
datatypes, RMAN keywords, SQL
keywords, SQL*Plus or utility commands,
packages and methods, as well as
system-supplied column names, database
objects and structures, usernames, and
roles.

You can specify this clause only for a NUMBER
column.

You can back up the database by using the
BACKUP command.

Query the TABLE_NAME column in the USER_
TABLES data dictionary view.

Use the DBMS_STATS.GENERATE_STATS
procedure.

lowercase
monospace
(fixed-width)
font

Lowercase monospace typeface indicates
executables, filenames, directory names,
and sample user-supplied elements. Such
elements include computer and database
names, net service names, and connect
identifiers, as well as user-supplied
database objects and structures, column
names, packages and classes, usernames
and roles, program units, and parameter
values.

Note: Some programmatic elements use a
mixture of UPPERCASE and lowercase.
Enter these elements as shown.

Enter sqlplus  to open SQL*Plus.

The password is specified in the orapwd  file.

Back up the datafiles and control files in the
/disk1/oracle/dbs  directory.

The department_id , department_name ,
and location_id  columns are in the
hr.departments  table.

Set the QUERY_REWRITE_ENABLED
initialization parameter to true.

Connect as oe  user.

The JRepUtil  class implements these
methods.

lowercase
italic
monospace
(fixed-width)
font

Lowercase italic monospace font
represents placeholders or variables.

You can specify the parallel_clause .

Run Uold_release .SQL  where old_
release refers to the release you installed
prior to upgrading.
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SELECT username FROM dba_users WHERE username = ’MIGRATE’;

The following table describes typographic conventions used in code examples and

provides examples of their use.

Convention Meaning Example

[ ] Brackets enclose one or more optional
items. Do not enter the brackets.

DECIMAL ( digits  [ , precision  ])

{ } Braces enclose two or more items, one of
which is required. Do not enter the
braces.

{ENABLE | DISABLE}

| A vertical bar represents a choice of two
or more options within brackets or braces.
Enter one of the options. Do not enter the
vertical bar.

{ENABLE | DISABLE}

[COMPRESS | NOCOMPRESS]

... Horizontal ellipsis points indicate either:

■ That we have omitted parts of the
code that are not directly related to
the example

■ That you can repeat a portion of the
code

CREATE TABLE ... AS subquery ;

SELECT col1 , col2 , ... , coln  FROM
employees;

 .

 .

 .

Vertical ellipsis points indicate that we
have omitted several lines of code not
directly related to the example.

Other notation You must enter symbols other than
brackets, braces, vertical bars, and ellipsis
points as shown.

   acctbal NUMBER(11,2);

   acct    CONSTANT NUMBER(4) := 3;

Italics Italicized text indicates placeholders or
variables for which you must supply
particular values.

CONNECT SYSTEM/system_password

DB_NAME = database_name

UPPERCASE Uppercase typeface indicates elements
supplied by the system. We show these
terms in uppercase in order to distinguish
them from terms you define. Unless terms
appear in brackets, enter them in the
order and with the spelling shown.
However, because these terms are not
case sensitive, you can enter them in
lowercase.

SELECT last_name, employee_id FROM
employees;

SELECT * FROM USER_TABLES;

DROP TABLE hr.employees;
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Conventions for Microsoft Windows Operating Systems
The following table describes conventions for Microsoft Windows operating

systems and provides examples of their use.

lowercase Lowercase typeface indicates
programmatic elements that you supply.
For example, lowercase indicates names
of tables, columns, or files.

Note: Some programmatic elements use a
mixture of UPPERCASE and lowercase.
Enter these elements as shown.

SELECT last_name, employee_id FROM
employees;

sqlplus hr/hr

CREATE USER mjones IDENTIFIED BY ty3MU9;

Convention Meaning Example

Choose Start > How to start a program. To start the Oracle Database Configuration
Assistant, choose Start > Programs > Oracle -
HOME_NAME > Configuration and Migration
Tools > Database Configuration Assistant.

File and directory
names

File and directory names are not case
sensitive. The following special characters
are not allowed: left angle bracket (<),
right angle bracket (>), colon (:), double
quotation marks ("), slash (/), pipe (|),
and dash (-). The special character
backslash (\) is treated as an element
separator, even when it appears in quotes.
If the file name begins with \\, then
Windows assumes it uses the Universal
Naming Convention.

c:\winnt"\"system32  is the same as
C:\WINNT\SYSTEM32

C:\> Represents the Windows command
prompt of the current hard disk drive.
The escape character in a command
prompt is the caret (^). Your prompt
reflects the subdirectory in which you are
working. Referred to as the command
prompt in this manual.

C:\oracle\oradata>

Convention Meaning Example
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The backslash (\) special character is
sometimes required as an escape
character for the double quotation mark
(") special character at the Windows
command prompt. Parentheses and the
single quotation mark (’) do not require
an escape character. Refer to your
Windows operating system
documentation for more information on
escape and special characters.

C:\>exp scott/tiger TABLES=emp
QUERY=\"WHERE job=’SALESMAN’ and
sal<1600\"

C:\>imp SYSTEM/ password
FROMUSER=scott TABLES=(emp, dept)

HOME_NAME Represents the Oracle home name. The
home name can be up to 16 alphanumeric
characters. The only special character
allowed in the home name is the
underscore.

C:\> net start Oracle HOME_
NAMETNSListener

ORACLE_HOME
and ORACLE_
BASE

In releases prior to Oracle8i release 8.1.3,
when you installed Oracle components,
all subdirectories were located under a
top level ORACLE_HOME directory that by
default used one of the following names:

■ C:\orant  for Windows NT

■ C:\orawin95  for Windows 95

■ C:\orawin98  for Windows 98

This release complies with Optimal
Flexible Architecture (OFA) guidelines.
All subdirectories are not under a top
level ORACLE_HOME directory. There is a
top level directory called ORACLE_BASE
that by default is C:\oracle . If you
install Oracle9i release 1 (9.0.1) on a
computer with no other Oracle software
installed, then the default setting for the
first Oracle home directory is
C:\oracle\ora90 . The Oracle home
directory is located directly under
ORACLE_BASE.

All directory path examples in this guide
follow OFA conventions.

Go to the ORACLE_BASE\ ORACLE_
HOME\rdbms\admin  directory.

Convention Meaning Example
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1
Introduction to the Configuration Editor

A profile is a group of settings edited by the configuration editors that can be

attached to a service to specify start up conditions during runtime. Oracle

Application Server InterConnect (OracleAS InterConnect) Configuration Editor

allows you to create and edit these profiles.

The following topics are discussed in this chapter:

■ Using the Master Key Setting Tool

■ Setting the Master Key

■ Multiple Users Using a Windows Development Machine (R/3 Specific)
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Using the Master Key Setting Tool
Profiles are sensitive to the Master Key setting. The role of the Master Key is to

encrypt security and password information, for example, for R/3 or PeopleSoft™,

provided in the Configuration Editor for a specific profile.

The iStudio browser uses the iStudio profile to access to various service provider

systems. If using a shared machine, and User1 has set a Master Key, ensure to set

the Master Key same as that of User1 before accessing the Configuration Editor. It is

also recommended to set the Master Key when you are exporting an iStudio profile

to another machine.
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Setting the Master Key
Use the Master Key Setting Tool to set the master key string. To start the Master Key

Setting Tool, type the following command at the command prompt:

chsetkey

■ On Windows—The browser brings up the Master Key Setting Tool dialog,

which prompts you to enter the master encryption key.

■ On Unix—The Master Key Setting Tool prompts you for a Master Key at the

command prompt.
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Figure 1–1 Master Key Setting Tool Dialog

You can use any alpha/numeric combination for the Master Key. After setting the

new Master Key, the new key is active and replaces any other key previously set. If

you are exporting the profile after you have set the master key, make sure to use the

same key when importing the profile on the other machines.

If you have previously used iStudio to expose components or to create events and

procedures, you do not have to redo any of your work. Setting the new key is

transparent to any work previously done.
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Multiple Users Using a Windows Development Machine (R/3 Specific)
If more than one person uses the same Windows Development machine, the

information in the default and reference login to R/3 is permanently corrupted. The

following example explains this statement:

1. User1 logs onto an Windows machine and sets the settings in the Configuration

Editor.

2. User1 logs out.

3. User2 logs in and accesses the profile settings. The information in the Default

and Reference logins are corrupt.

4. User2 logs out.

5. User1 logs in again and accesses the Configuration Editor. The values in the

Default and Reference logins are corrupt.



Multiple Users Using a Windows Development Machine (R/3 Specific)

1-6 Oracle Application Server InterConnect Configuration Editor User’s Guide

Work Around
The following example provides a workaround for the corruption of the default and

reference log in:

1. User1 logs onto an Windows machine and creates a profile or uses an existing

profile.

2. User1 uses the Master Key utility to enter a key.

3. User1 logs off.

4. User2 logs on.

5. Before User2 accesses any product features such as the Configuration Editor,

User2 must use the Master Key utility to enter the same key that User1 had

created. From then on, there is no further corruption of data.

Note: Any additional user on that machine must use the same

procedure as User2.
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2
Using the Configuration Editor

This chapter describes how to use the Configuration Editor to create and edit

profiles. The following topics are discussed:

■ Starting the Configuration Editor

■ Getting Help

■ Menu Items

■ Creating a Profile

■ Exporting a Profile

■ Importing a Profile
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Starting the Configuration Editor
To start the Configuration Editor using a command prompt:

1. Change directories to the installation directory.

2. Type configeditor .

3. Press Enter.

The Configuration Editor displays.

Figure 2–1 Configuration Editor Main Menu
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The following list describes the components on this dialog:

■ Global Settings—Used to change the default values. Each adapter can have its

own default values set by a user under the [GLOBAL SETTINGS]  profile for

that adapter.

You can change individual user defined-profile settings by unchecking Use
Global Settings in the Configuration Editor. Changing these settings will not

affect the [GLOBAL SETTINGS]  values.

■ Profile—Used to create a new profile.

See Also: "Creating a Profile" on page 2-6
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Getting Help
In any dialog displayed by the Configuration Editor help is available to explain the

fields in all of the dialogs. To activate help:

1. Click in a field for which you need an explanation.

2. Click F1.

A dialog containing a description of the field(s) displays.

Figure 2–2 Configuration Settings Editor Dialog
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Menu Items
At the top of the dialog are two menu items. Table 2–1 describes the menu items

and their submenus.

Table 2–1 Menu Items

 Menu Selection Description

File Save Settings Save the current change.

Save All Settings Save multiple changes at the same time.

Revert Restore original settings. If you modify a setting and it is
not incorrect, use revert to back out of the modification.

Import Profile Import previously exported profiles.

Export Profile Export the profile. Also used to save profile configuration
data to import after a product upgrade.

Exit Exit the Configuration Editor.

Profile Create a Profile Create new profiles.

Delete a Profile Delete an existing profile.

Set as Default
Profile

Set a profile as the start-up profile.
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Creating a Profile
To create a new profile:

1. Select Profile->Create a Profile from the dropdown menu.

The Create Profile dialog displays.

Figure 2–3 Create Profile Dialog

2. Enter a profile name in the Create Profile field.

A profile name is any combination of alpha or numeric characters to a length of

32 characters. Spaces are not allowed.
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3. Click OK.

The new empty profile displays in the Profile dropdown list and in the settings

database.

Figure 2–4 New Profile Drop Down List

Note: Currently running services are not affected by any change

to the profiles. After editing an existing profile, restart any

application using the service to update the resources.

Note: If the Configuration Editor is running on a UNIX system

and you close the Configuration Editor after creating a new profile,

profile information is not saved.

To save the newly created profile, edit the settings of any adapter

for that profile and then save the profile information.
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Exporting a Profile
An exported profile contains all the configuration settings previously set. It also

contains the Master Key code to unlock password protected values if the Master

Key was set on the machine.

1. Select File->Export Profile to export your profile.

The Select Profile to Export dialog displays.

2. Select a specific profile to export using the dropdown list or click All Settings to

export all profiles.

Figure 2–5 Select a Profile for Export

3. Enter a filename to save the parameters in the To File field. For exmaple,

parameters.txt .

4. Click OK to save the profile to a file and exit the dialog.
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Importing a Profile
Importing a profile is useful if you want other machines to have the same setup as

your development machine. To import a profile:

1. Select File->Import Profile to import your profile.

The Import Profile dialog displays.

Figure 2–6 Importing a Profile Dialog
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2. Enter a file name containing the export configuration parameters in the File
field.

To browse for a file, click ... (browse). The File Selection dialog displays.

Figure 2–7 File Selection Dialog
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3. Select a profile and click Import to return to the Import Profile dialog.

4. Check Import Using Source Master Key if the machine from which you are

importing has a Master Key set.

5. Enter the same Master Key as set on the machine from which you are importing

the profile.

6. Click OK.
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