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Preface

This manual describes how to use the Oracle Email Migration Tool packaged with 
Oracle Collaboration Suite and provides information about the Migration Tool, the 
Migration Setup Wizard, and the tasks you perform to migrate e-mail systems to the 
Oracle Email component of Oracle Collaboration Suite.

This preface contains these topics:

■ Audience

■ Organization

■ Related Documentation

■ Conventions

■ Documentation Accessibility
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Audience
The Oracle Email Migration Tool Guide is intended for system administrators, e-mail 
administrators, and people involved in planning e-mail systems for organizations 
migrating users from Oracle eMail Server 5.2.x or Microsoft Exchange 5.0 and 5.5 to 
Oracle Email.

To use this document, you must have an understanding of Oracle e-mail server 
administration.

Organization
This document contains:

Chapter 1, "Introduction to Oracle Email Migration Tool"
Introduces the Migration Tool and provides an overview of the migration process.

Chapter 2, "Migration Planning and Using the Oracle Email Migration 
Tool"
Explains planning for migration and focuses on configuration, plug-ins, and routing 
reconfiguration planning.

Chapter 3, "Migration Tasks"
Describes pre-migration, migration, and post-migration tasks for e-mail.

Appendix A, "Plug-in Generated File Formats"
Provides file formats and examples of generated files including user-list, 
distribution lists, public aliases, shared folders, and server-side rules.

Appendix B, "API Architecture"
Provides guidelines for developing plug-ins to migrate other third party e-mail 
systems.

Related Documentation
For more information, see these Oracle resources in the Oracle Collaboration Suite 
Release 9.0.3 documentation set:

■ Oracle Collaboration Suite Administrator’s Guide
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■ Oracle Collaboration Suite Installation Guide

■ Oracle Collaboration Suite Release Notes

■ Check the Oracle Technology Network Web site for new and updated 
documentation.

In North America, printed documentation is available for sale in the Oracle Store at

http://oraclestore.oracle.com/
Customers in Europe, the Middle East, and Africa (EMEA) can purchase 
documentation from

http://www.oraclebookshop.com/

Other customers can contact their Oracle representative to purchase printed 
documentation.

To download free release notes, installation documentation, white papers, or other 
collateral, please visit the Oracle Technology Network (OTN). You must register 
online before using OTN; registration is free and can be done at

http://otn.oracle.com/admin/account/membership.html

If you already have a username and password for OTN, then you can go directly to 
the documentation section of the OTN Web site at

http://otn.oracle.com/docs/index.htm

To access the database documentation search engine directly, please visit

http://tahiti.oracle.com

For additional information, see:

■ http://msdn.microsoft.com

Conventions
This section describes the conventions used in the text and code examples of this 
documentation set. It describes:

■ Conventions in Text

■ Conventions in Code Examples

■ Conventions for Windows Operating Systems
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Conventions in Text
We use various conventions in text to help you more quickly identify special terms. 
The following table describes those conventions and provides examples of their use.

Convention Meaning Example

Bold Bold typeface indicates terms that are 
defined in the text or terms that appear in 
a glossary, or both.

When you specify this clause, you create an 
index-organized table. 

Italics Italic typeface indicates book titles or 
emphasis.

Oracle9i Database Concepts

Ensure that the recovery catalog and target 
database do not reside on the same disk.

UPPERCASE 
monospace 
(fixed-width) 
font

Uppercase monospace typeface indicates 
elements supplied by the system. Such 
elements include parameters, privileges, 
datatypes, RMAN keywords, SQL 
keywords, SQL*Plus or utility commands, 
packages and methods, as well as 
system-supplied column names, database 
objects and structures, usernames, and 
roles.

You can specify this clause only for a NUMBER 
column.

You can back up the database by using the 
BACKUP command.

Query the TABLE_NAME column in the USER_
TABLES data dictionary view.

Use the DBMS_STATS.GENERATE_STATS 
procedure.

lowercase 
monospace 
(fixed-width) 
font

Lowercase monospace typeface indicates 
executables, filenames, directory names, 
and sample user-supplied elements. Such 
elements include computer and database 
names, net service names, and connect 
identifiers, as well as user-supplied 
database objects and structures, column 
names, packages and classes, usernames 
and roles, program units, and parameter 
values.

Note: Some programmatic elements use a 
mixture of UPPERCASE and lowercase. 
Enter these elements as shown.

Enter sqlplus to open SQL*Plus.

The password is specified in the orapwd file.

Back up the datafiles and control files in the 
/disk1/oracle/dbs directory.

The department_id, department_name, 
and location_id columns are in the 
hr.departments table.

Set the QUERY_REWRITE_ENABLED 
initialization parameter to true.

Connect as oe user.

The JRepUtil class implements these 
methods.

lowercase 
italic 
monospace 
(fixed-width) 
font

Lowercase italic monospace font 
represents placeholders or variables.

You can specify the parallel_clause.

Run Uold_release.SQL where old_
release refers to the release you installed 
prior to upgrading.
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Conventions in Code Examples
Code examples illustrate SQL, PL/SQL, SQL*Plus, or other command-line 
statements. They are displayed in a monospace (fixed-width) font and separated 
from normal text as shown in this example:

SELECT username FROM dba_users WHERE username = ’MIGRATE’;

The following table describes typographic conventions used in code examples and 
provides examples of their use.

Convention Meaning Example

[ ] Brackets enclose one or more optional 
items. Do not enter the brackets.

DECIMAL (digits [ , precision ])

{ } Braces enclose two or more items, one of 
which is required. Do not enter the braces.

{ENABLE | DISABLE}

| A vertical bar represents a choice of two 
or more options within brackets or braces. 
Enter one of the options. Do not enter the 
vertical bar.

{ENABLE | DISABLE}

[COMPRESS | NOCOMPRESS]

... Horizontal ellipsis points indicate either:

■ That we have omitted parts of the 
code that are not directly related to 
the example

■ That you can repeat a portion of the 
code

CREATE TABLE ... AS subquery;

SELECT col1, col2, ... , coln FROM 
employees;

 .

 .

 .

Vertical ellipsis points indicate that we 
have omitted several lines of code not 
directly related to the example.

Other notation You must enter symbols other than 
brackets, braces, vertical bars, and ellipsis 
points as shown.

   acctbal NUMBER(11,2);

   acct    CONSTANT NUMBER(4) := 3;

Italics Italicized text indicates placeholders or 
variables for which you must supply 
particular values.

CONNECT SYSTEM/system_password

DB_NAME = database_name
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Conventions for Windows Operating Systems 
The following table describes conventions for Windows operating systems and 
provides examples of their use.

UPPERCASE Uppercase typeface indicates elements 
supplied by the system. We show these 
terms in uppercase in order to distinguish 
them from terms you define. Unless terms 
appear in brackets, enter them in the 
order and with the spelling shown. 
However, because these terms are not 
case sensitive, you can enter them in 
lowercase.

SELECT last_name, employee_id FROM 
employees;

SELECT * FROM USER_TABLES;

DROP TABLE hr.employees;

lowercase Lowercase typeface indicates 
programmatic elements that you supply. 
For example, lowercase indicates names 
of tables, columns, or files.

Note: Some programmatic elements use a 
mixture of UPPERCASE and lowercase. 
Enter these elements as shown.

SELECT last_name, employee_id FROM 
employees;

sqlplus hr/hr

CREATE USER mjones IDENTIFIED BY 
ty3MU9;

Convention Meaning Example

Choose Start > How to start a program. To start the Database Configuration Assistant, 
choose Start > Programs > Oracle - HOME_
NAME > Configuration and Migration Tools > 
Database Configuration Assistant.

File and directory 
names

File and directory names are not case 
sensitive. The following special characters 
are not allowed: left angle bracket (<), 
right angle bracket (>), colon (:), double 
quotation marks ("), slash (/), pipe (|), 
and dash (-). The special character 
backslash (\) is treated as an element 
separator, even when it appears in quotes. 
If the file name begins with \\, then 
Windows assumes it uses the Universal 
Naming Convention.

c:\winnt"\"system32 is the same as 
C:\WINNT\SYSTEM32

Convention Meaning Example
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C:\> Represents the Windows command 
prompt of the current hard disk drive. 
The escape character in a command 
prompt is the caret (^). Your prompt 
reflects the subdirectory in which you are 
working. Referred to as the command 
prompt in this manual.

C:\oracle\oradata>

The backslash (\) special character is 
sometimes required as an escape 
character for the double quotation mark 
(") special character at the Windows 
command prompt. Parentheses and the 
single quotation mark (’) do not require 
an escape character. Refer to your 
Windows operating system 
documentation for more information on 
escape and special characters.

C:\>exp scott/tiger TABLES=emp 
QUERY=\"WHERE job=’SALESMAN’ and 
sal<1600\"

C:\>imp SYSTEM/ password 
FROMUSER=scott TABLES=(emp, dept)

HOME_NAME Represents the Oracle home name. The 
home name can be up to 16 alphanumeric 
characters. The only special character 
allowed in the home name is the 
underscore. 

C:\> net start Oracle HOME_
NAMETNSListener

Convention Meaning Example
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Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle Corporation is actively engaged with other 
market-leading technology vendors to address technical obstacles so that our 

ORACLE_HOME 
and ORACLE_
BASE

In releases prior to Oracle8i release 8.1.3, 
when you installed Oracle components, 
all subdirectories were located under a 
top level ORACLE_HOME directory that by 
default used one of the following names:

■ C:\orant for Windows NT

■ C:\orawin95 for Windows 95

■ C:\orawin98 for Windows 98

This release complies with Optimal 
Flexible Architecture (OFA) guidelines. 
All subdirectories are not under a top 
level ORACLE_HOME directory. There is a 
top level directory called ORACLE_BASE 
that by default is C:\oracle. If you 
install the latest Oracle release on a 
computer with no other Oracle software 
installed, then the default setting for the 
first Oracle home directory is 
C:\oracle\orann, where nn is the 
latest release number. The Oracle home 
directory is located directly under 
ORACLE_BASE.

All directory path examples in this guide 
follow OFA conventions.

Refer to Oracle9i Database Getting Starting 
for Windows for additional information 
about OFA compliances and for 
information about installing Oracle 
products in non-OFA compliant 
directories.

Go to the ORACLE_BASE\ORACLE_
HOME\rdbms\admin directory.

Convention Meaning Example
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documentation can be accessible to all of our customers. For additional information, 
visit the Oracle Accessibility Program Web site at

http://www.oracle.com/accessibility/

Accessibility of Code Examples in Documentation JAWS, a Windows screen 
reader, may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, JAWS may not always read a line of text that 
consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation This 
documentation may contain links to Web sites of other companies or organizations 
that Oracle Corporation does not own or control. Oracle Corporation neither 
evaluates nor makes any representations regarding the accessibility of these Web 
sites.
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1
Introduction to Oracle Email Migration Tool

This chapter provides an overview of the Oracle Email Migration Tool.

This chapter contains these topics:

■ What Is the Oracle Email Migration Tool?

■ Who Uses the Oracle Email Migration Tool?

■ Overview of the Migration Process
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What Is the Oracle Email Migration Tool?
E-mail migration is usually a tedious and intricate process. It requires migration of 
accounts, server-side rules, folders, e-mail messages, distribution lists, shared 
folders, public aliases, and Web Client address books, as well as changes to the 
Simple Mail Transfer Protocol (SMTP) routing. Migrating a large e-mail system with 
minimal downtime is a challenging task.

The Oracle Email Migration Tool facilitates migration of users to Oracle Email from 
Oracle eMail Server 5.2.1 and Microsoft Exchange 5.0 and 5.5.

For migration, a system administrator requires the following utilities:

■ The base Migration Tool

■ A plug-in developed specifically for the source e-mail server

The plug-in communicates with the source e-mail system to extract data from the 
source message store, which it saves in a format understood by the Migration Tool. 
Once the required files are generated, the Migration Tool reads the files and 
migrates them to Oracle Email. The plug-in and the Migration Tool communicate 
through an API.

The logs generated by the Migration Tool are written to the text.log file located 
in the log/migration/uniquenumber directory where you unzip the 
esmigration.zip file.

Who Uses the Oracle Email Migration Tool?
The Migration Tool is designed specifically to migrate large mail systems, such as:

■ Corporate installations that generally have a few thousand to hundreds of 
thousands of users with large mailboxes (tens to hundreds of megabytes).

Note: There are plug-ins for Oracle eMail Server and Microsoft 
Exchange source e-mail systems packaged with the Migration Tool.

See Also:

■ Appendix B, "API Architecture" for information about APIs

■ "Installing the Migration Tool" on page 3-3 for directory 
information
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■ Internet service providers that generally have a large number of users (millions) 
with small mailboxes (a few hundred kilobytes).

Overview of the Migration Process
Migrating a mail system involves migrating account information and migrating 
data, and routing of new and future messages to the target Oracle Email server.

 This section contains the following topics:

■ Migrating Accounts

■ Migrating Data

Migrating Accounts
The Migration Tool extracts account information, including user names, public 
aliases, distribution lists, and server-side rules from the source directory server or 
user profiles file and places it into the target Oracle Email system and the target 
Oracle Internet Directory, as shown in Figure 1–1.

Figure 1–1 Account Migration

Note: The target Oracle Internet Directory and the source 
directory server can be the same or different servers.

Oracle
Internet

Directory

Oracle Email
Migration Tool

Source Directory or
User Profiles File

Target 
Oracle Email 

Message Store
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Migrating Data
Migrating user data is a major part of migration and involves the most resources of 
the system on which the Migration Tool is installed. The following operations occur 
during data migration: 

■ Messages, folders, and shared folders are migrated

For shared messages, the Migration Tool inserts one copy of a message into the 
database and provides a pointer for every recipient of the same message, as 
opposed to having a copy of the message sent to each recipient. This can 
potentially save an enormous amount of disk space that would otherwise be 
taken up by duplicate e-mail messages.

■ Server-side rules are migrated

■ Routing of new messages to Oracle Email

■ Verification of successful migration

The Migration Tool migrates data using either MBOX- or IMAP-based migration.

MBOX-Based Migration
If the source e-mail server does not support IMAP, as is the the case with Microsoft 
Exchange 5.0, the Migration Tool uses the plug-in to create MBOX files for each user 
in an MBOX directory. In the MBOX directory, messages that belong to a particular 
folder are successively appended to an MBOX file.

The Migration Tool requests MBOX directory location information as input from the 
administrator into the Migration Setup Wizard. An overview of the process is 
shown in Figure 1–2.

See Also: "Verifying Migration" on page 3-38 for more 
information about verification

Note: If the source e-mail server does not support IMAP, Oracle 
Corporation recommends selecting an MBOX-based migration.
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Figure 1–2 Overview of the Mechanics of MBOX Based Migration

If your source e-mail system does not support IMAP, as is the case with Microsoft 
Exchange 5.0, the Migration Tool generates an MBOX file that you can store on an 
intermediate system before being migrated to Oracle Email.

You can choose to retain the user names from the source system, or direct the 
Migration Tool to generate new target user names based on rules you create.

See Also: "Step 1: Specifying Mail System Objects" on page 3-12 
for information on selecting a migration option

See Also: "Step 8: Specifying New Account User Names" on 
page 3-24 for information on generating new target user names

Oracle Email
Msg Store

and Mig Tool
Repository

MS LDAP
Directory

Repository

MS
Exchange
Message

Store

Oracle Email
IMAP Server

Migration
Setup
Wizard

Oracle
Email

Migration
Tool

MS
Exchange

Plug-in

MBOX Files

Messages and 
Folders

MAPI

MAPI
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IMAP-Based Migration
During an IMAP-based migration, the Migration Tool extracts the data from the 
source e-mail system message store and places it directly into the target e-mail 
system message store, as shown in Figure 1–3.

Figure 1–3 Overview of the Mechanics of IMAP Based Migration

Note: MBOX-based migration can be used in an IMAP-supported  
source e-mail server to avoid source password requirements. 

Oracle Email
IMAP Server

Source
IMAP

Server

Migration
Setup
Wizard

Oracle
Email

Migration
Tool

Messages 
and
Folders

Target Oracle
Email Store

and
Migration Tool

Repository

Oracle EMail
Server

Message
Store
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2
Migration Planning and Using the Oracle

Email Migration Tool

This chapter provides migration planning information.

This chapter contains these topics:

■ Requirements Before Migration

■ System Requirements

■ Configuration Planning

■ Using the Oracle Email Migration Tool
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Requirements Before Migration
Before starting a migration, at least one instance of Oracle Collaboration Suite and 
Oracle Internet Directory must be installed on the target system.

System Requirements
The Migration Tool can be run on either the source system, an intermediate system, 
or the target system. This section describes the following system requirements for 
the machine on which the Migration Tool is running:

■ Memory

■ Disk Space

■ Network Bandwidth

■ Microsoft Requirements

■ Intermediate Storage of Data During Migration

Memory
The minimum memory requirement is 512 megabytes (MB) of random access 
memory (RAM).

Disk Space
The disk space requirement is:

■ 300 MB for migrating 10 users concurrently from MBOX, assuming a quota of 
20 MB for each user (including all the intermediate store files) 

■ 70 MB for migrating from IMAP

Note: The Microsoft Exchange plug-in has a feature called 
Statistics Task that you can use to estimate your disk space 
requirements if you are migrating from a Microsoft Exchange 
source e-mail system. This feature is available after you install the 
Migration Tool.
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Network Bandwidth
The Migration Tool network bandwidth requirements are the same as those for 
IMAP4 clients, although, for high speed migrations, more bandwidth is required. 
Oracle Corporation recommends 100 megabits per second (Mbps).

Microsoft Requirements
Microsoft Outlook 97, Microsoft Outlook 98, or Microsoft Outlook 2000, and 
Microsoft Exchange Administrator must be installed on the machine where you 
want to generate the various files (such as user list, MBOX, and shared folders) if 
migrating from Microsoft Exchange to Oracle Email.

The following Microsoft Exchange Server Services must be configured and set up 
properly:

■ Microsoft Exchange Internet Mail Service

■ Microsoft Exchange Information Store

■ Microsoft Exchange System Attendant

■ Microsoft Exchange Event Service

■ Microsoft Exchange Directory Service

See Also: "Using Statistics Task to Estimate Disk Space 
Requirements (Optional)" on page 3-6 for information about using 
the Statistics Task feature

Note: Migration runs well on a local area network (LAN) with at 
least 10 Mbps.
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Intermediate Storage of Data During Migration
During an MBOX based data migration, sufficient disk space must be available for 
intermediate storage to hold all of the e-mail of all the users being migrated 
together.

Configuration Planning
Configuration planning involves the following:

■ Choosing the Migration Option

■ Routing Reconfiguration Planning

■ Supporting Different Character Sets

Choosing the Migration Option
Choose one of the following options for data migration:

■ IMAP-based (IMAP to IMAP) migration for Microsoft Exchange 5.5 and Oracle 
eMail Server source e-mail systems

■ MBOX-based (MBOX to IMAP) migration for Microsoft Exchange 5.0 source 
e-mail systems

Notes:

■ If you are migrating from a Microsoft Exchange source e-mail 
system and running the Migration Tool on a machine other 
than the one upon which Microsoft Exchange is installed, 
ensure that Microsoft Outlook and Microsoft Exchange 
Administrator are installed on the machine from which you are 
running the Migration Tool.

■ A user profile file cannot be generated from a machine where a 
Microsoft Exchange e-mail client is not installed.

Note: The Migration Tool does not delete generated MBOX files.

See Also: Oracle Collaboration Suite Installation Guide for Oracle 
Email sizing guidelines
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For each of these types of migrations, you can choose to retain your source system 
user names, or to have the Migration Tool generate new target user names on rules 
you create.

Routing Reconfiguration Planning
The mail system is always available to a user. Prior to migrating a user’s data, the 
Migration Tool routes all of the user’s new mail to Oracle Email. The user can still 
access old mail on the source account until data migration for the user is complete.

Once data migration is complete for a user, an e-mail notification is sent to the user's 
new account stating that migration is complete and that old and new e-mail can be 
accessed in the new Oracle Email account.

If you receive an Unable to start directory services error message from the 
Microsoft Exchange plug-in, the error is logged in the ..\log\msplugin_
username@source_domain.log file.

If an error occurs during data migration, the user’s e-mail continues to be routed to 
the user’s new account. If the Migration Tool fails to route the user, the migration 
fails.

Supporting Different Character Sets
See the Oracle Collaboration Suite Administrator’s Guide for information about 
configuring the Oracle Email database to support different character sets.

Using the Oracle Email Migration Tool 
The Migration Tool has various menu bar selections and methods for viewing 
information about users, source domains, batches, and migration status.

Initially, all menu selections except Tools > Migration Setup are disabled. You must 
run the Migration Setup Wizard at least once for the directory tree on the left side of 
the screen to be populated and the menu selections to be available.

The Migration Setup Wizard stores migration parameters in the database every time 
you run the wizard. The Migration Setup Wizard picks up the prior settings from 
the database each time it is run.

Note: MBOX based migration can also be used to migrate from 
Microsoft Exchange 5.5 source e-mail systems.
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This section contains the following topics:

■ Overview of the Oracle Email Migration Tool Screen

■ Displaying User, Domain, Batch, and Migration Status Information

■ User States During Migration

■ Tuning for Performance

■ Viewing Log Files

Overview of the Oracle Email Migration Tool Screen
This section contains an overview of the Migration Tool screen.

This section contains the following topics:

■ Migration Tool Screen Menu Selections

■ Migration Tool Screen Fields

Migration Tool Screen Menu Selections
Figure 2–1 shows the menu selections on the Migration Tool screen.

Figure 2–1 Migration Tool Screen Menu Selections

■ File: The File menu has only the Exit selection, which shuts down the Migration 
Tool. Any ongoing migrations are canceled. No rollback or state saving is 
performed.

■ Extract: The Extract menu selections generate the following files in the 
Migration Tool files directory (except where noted):

– Users: The users.xml file

See Also: "Task 3: Setting Up a Migration Session" on page 3-11 
for information about the Migration Setup Wizard
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– Public aliases: The public_aliases.ldif file

– Distribution lists: The distribution_lists.ldif file

– Shared folders: The shared_folders.ldif file

– User Profiles: The user_profiles.ldif file

■ Batch: The Batch menu has only the Create selection, which displays a screen in 
which you enter the type of batch that you want to create.

■ Migrate: The Migrate menu contains the following selections:

– Create Users on Oracle: Starts the migration of user accounts to the target 
Oracle Email server

– Migrate Shared Folders: Starts the migration of shared folders

– Migrate Public Aliases: Starts the migration of public aliases

– Migrate Distribution Lists: Starts the migration of distribution lists

– Migrate User Data: Starts the migration of user data

– Pre-Migrate User Data: Starts premigration of user data

– Migrate Address Book: Starts the migration of users’ WebMail address 
books

– Cancel Migration: Cancels data migration. No rollback is performed and 
migration is terminated immediately

■ Tools: The Tools menu contains the following selections:

Note: users.xml is not extracted into the files directory. If you 
are extracting a user-list file for a domain called oracle.com, the 
file is generated in the files/com/oracle directory.

See Also: "Task 6: Batching" on page 3-31 for more information 
about creating batches

See Also: "Performing a Two-Phase Migration" on page 3-29 for 
more information about pre-migrating user data
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– Migration Setup: Launches the Migration Setup Wizard. If the Migration 
Tool is being run for the first time or if you have cleared the migration 
parameters, this is the only menu selection enabled.

– Load Users: Loads user information into the migration repository for later 
retrieval

– Modify User Details: Displays a screen in which you enter the source user 
name for the user whose details you want to modify, and which contains 
fields for modifying the user’s information

– Modify Migration Parameters: Displays a screen in which you can edit 
various migration parameters

– Clear Migration Parameters: Clears the migration parameters stored in the 
migration repository. The only menu option now enabled is Migration 
Setup to launch the Migration Setup Wizard.

– Verify New Accounts: Displays the Verification screen and gives 
information about an individual user’s migration status by comparing the 
source and target accounts

■ Help: The Help menu contains the following selections:

– Contents: Displays the online help

– About: Displays information about the release of the Migration Tool

Note: You can also select a user from the directory tree. Select the 
user and select Tools > Modify User Details to proceed with 
modifying the user’s details.

See Also: Figure 3–10, "Modify Migration Parameters Screen" on 
page 3-27

See Also: "Verifying Migration" on page 3-38 for more 
information about verification
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Migration Tool Screen Fields
Figure 2–2 shows the right side of the Migration Tool screen when the Migration 
View node is selected.

Figure 2–2 Migration Tool Screen Fields

■ The number of users currently migrating is displayed at the top of the section

■ Migrating Users: Displays the Domain, Batch, and User Name of users that are 
in a current state of migration

■ User Details: Displays user details of a user selected from the User Name 
column of the Migrating Users field

Note: When more than one Migration Tool instance runs against a 
single repository, each instance picks up users independently. The 
Migration View for a particular instance will show only the users 
that are being migrated by that instance in these two fields. Users 
listed in the directory tree might not be listed in the Migrating 
Users field. If you select a user from the directory tree and find that 
their status is Migrating, it means that the user is being migrated 
by another instance.
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Displaying User, Domain, Batch, and Migration Status Information
You can display user, domain, batch, and migration status information using the 
Migration Tool screen. You can also edit the scheduled start time for migrating a 
batch using the Migration Tool screen.

This section contains the following topics:

■ Viewing Domain, Batch, and User Information

■ Displaying Source Domain Information and Migration Status

■ Displaying Batch Information and Migration Status

■ Displaying User Information and Status from the Directory Tree View

Viewing Domain, Batch, and User Information
You can expand the various nodes of the directory tree on the left side of the 
Migration Tool screen to display specific information.

■ When you expand MigrationView, all the source domains display

■ When you expand a domain, all the batches in the domain display

■ When you expand a batch, all the users belonging to the batch display

Displaying Source Domain Information and Migration Status
All the domains on the source system you want to migrate are listed under 
MigrationView in the directory tree on the left side of the Migration Tool screen. To 
view the information and migration status for a particular source domain, as shown 
in Figure 2–3, select the source domain.

Figure 2–3 Migration Tool Screen with Source Domain Information Displayed
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The following information displays:

■ Status (Pending, Migrating, Done, or Failed)

■ Number of batches in the domain

■ Number of users in the domain

■ Scheduled start time of first batch

■ Scheduled start time of last batch

Displaying Batch Information and Migration Status
To monitor batch information, expand a domain to view the batches in the domain. 
Select a batch name to view information and migration status, as shown in 
Figure 2–4.

Figure 2–4 Migration Tool Screen with Batch Information Displayed

When you select a batch from the directory tree on the left side of the Migration 
Tool screen, the details for the selected batch display on the right side, showing the 
following information:

■ Domain to which the batch belongs

■ Status (Pending, Migrating, Done, or Failed)

■ Number of Users in the batch

■ Scheduled start time (you can edit the date and time field and click Schedule 
to save the changes)

■ Users migrated (the percentage of users migrated)
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Displaying User Information and Status from the Directory Tree View
To view all the users belonging to a particular batch, expand the batch. To view a 
specific user’s information and migration status, as shown in Figure 2–5, click their 
user name.

Figure 2–5 Migration Tool Screen with User Information Displayed

When you select a user from the directory tree on the left side of the Migration Tool 
screen, the details for the selected user display, showing the following information:

■ Domain to which the user belongs

■ Batch to which the user belongs

■ Status (Pending, Migrating, Done, or Failed)

■ Number of folders

■ Migration start time

Note: If a single user in a batch fails to migrate, the entire batch is 
marked as Failed and must be rescheduled for migration. Users 
that migrated successfully are not migrated a second time.

See Also: "Task 6: Batching" on page 3-31 for more information 
about batches
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■ Migration end time

■ Folders migrated

■ Total bytes written

■ Folders migrated in % (the percentage of folders migrated)

User States During Migration
A user is assigned one of the states shown in Table 2–1 during the data migration 
process.

Tuning for Performance
The read and write speeds are displayed at the bottom of the main Migration Tool 
screen. They indicate the performance of the Migration Tool.

You can increase or decrease the number of users migrating concurrently to 
optimize performance.

If you have two batches scheduled to migrate at times that overlap each other, the 
migration speed does not increase. The number of users that are migrated 

Note: If one folder fails to migrate, the user is marked as Failed 
and must be migrated again.

Table 2–1 Migration States

State Description

Pending The user is yet to migrate

Migrating The user is currently migrating

Done The user was successfully migrated

Failed The user’s migration failed, for example, due to failure of routing 
or mail migration

Failed users do not receive completion notifications

See Also: "Displaying User, Domain, Batch, and Migration Status 
Information" on page 2-10 for information about viewing user 
states in the Migration Tool screen
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concurrently is a fixed number specified by an administrator in the Migration Setup 
Wizard.

Viewing Log Files
Log files are generated in the log directory of the Migration Tool. Every run of the 
Migration Tool generates a new log file that an administrator can open in any text 
editor to view the contents. Log files should be viewed frequently throughout the 
migration process.

The logs should be viewed after each of the following tasks to ensure successful 
migration:

■ Extraction of accounts, shared folders, public aliases, and distribution lists

■ Extraction of an MBOX file (Migration_default.log)

■ Migration of data, accounts, shared folders, public aliases, and distribution lists

■ Routing a user

See Also: "Step 2: Specifying Migration Options" on page 3-13 to 
change the number of concurrently migrating users

Note: Any extraction failures of the Migration Tool are logged in 
the text.log file.

Note: When you select MBOX based migration, MBOX files are 
generated by the plug-in. View the Migration_default.log file 
for failed users. If you find that a user has failed, view the 
msplugin_username@source_domain.log file to find the error 
message logged by the plug-in application.
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3
Migration Tasks

This chapter provides information about migration tasks.

This chapter contains these topics:

■ Administrator Responsibilities Before Migration

■ Task 1: Starting the Migration Tool

■ Task 2: Logging In to the Migration Repository

■ Task 3: Setting Up a Migration Session

■ Task 4: Migrating Users to Oracle Email

■ Task 5: Extracting Mail System Objects from the Source System

■ Task 6: Batching

■ Task 7: Migrating Shared Folders

■ Task 8: Migrating Public Aliases

■ Task 9: Migrating Distribution Lists

■ Task 10: Migrating WebMail Address Books

■ Task 11: Migrating Data

■ Post-Migration Administrator Responsibilities
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Administrator Responsibilities Before Migration

This section contains the following topics:

■ Configuring the Domain Name Server Entry

■ IMAP Server Configuration

■ Verifying Source and Target IMAP Server Ports

■ Installing the Migration Tool

■ Setting Up the Oracle eMail Server Plug-In

■ Preparing for a Microsoft Exchange Migration

Configuring the Domain Name Server Entry
You must configure the DNS entry prior to beginning the migration process so that 
the target Oracle Email server is visible to the rest of the internet.

IMAP Server Configuration
The source IMAP servers should be suitably configured for a possibly large number 
of IMAP connections for concurrently migrating users. This includes database 
configuration for the source and target systems, if required.

The IMAP connection requirements are one connection per concurrent user on the 
source IMAP server and three connections per concurrent user on the target IMAP 
server.

To deploy message sharing in JMA based migrations, you must configure the IMAP 
server as follows:

1. Use the Oracle Enterprise Manager administrator pages to add the value 
MigrationHeader=Message-ID to the Process Flag IMAP server process 
parameter.

2. Restart the IMAP server prior to running the Migration Tool.

Note: At least one instance of Oracle Collaboration Suite, with the 
Email Server component, and Oracle Internet Directory must be 
installed on the target system prior to installing the Migration Tool.
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Verifying Source and Target IMAP Server Ports
If you are performing an IMAP-based migration, verify that both the source and 
target IMAP servers are configured on port 143.

If you are performing an MBOX-based migration, verify that the target IMAP server 
only is configured on port 143.

Installing the Migration Tool
The Migration Tool can be run on both Windows NT and UNIX platforms.

This section contains these topics:

■ Setting Up JREHOME on UNIX

■ Setting Up JREHOME on Windows NT

To install the Migration Tool:

1. Unzip the esmigration.zip file.

For UNIX operating systems, enter the following:

unzip esmigration.zip

See Also: Oracle Email Administrator’s Guide for information about 
setting up process parameters on your IMAP server

See Also: Oracle Email Administrator’s Guide for target IMAP 
server configuration information

Note:

■ All source Microsoft Exchange servers in the currently 
migrating site must stay up for the entire duration of the 
migration.

■ If you are migrating from a Microsoft Exchange source e-mail 
system and running the Migration Tool on a machine other 
than the one upon which Microsoft Exchange is installed, 
ensure that Microsoft Outlook and Microsoft Exchange 
Administrator are installed on the machine from which you are 
running the Migration Tool.
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For Windows NT operating systems, use WinZip to unzip and extract all files 
from the esmigration.zip file.

For either operating system, the following files and directories are created 
where you unzip the esmigration.zip file: doc, help, log, files, bin, 
images, sql, config, lib, and esmsplugin.tar.

2. Set up the JREHOME environment variable to point to the Java Runtime 
Environment (JRE) 1.3.1 directory.

Setting Up JREHOME on UNIX
To set up JREHOME on UNIX operating systems, do the following:

■ For C-Shell, enter the following:

setenv JREHOME directory_containing_JDK_131

■ For Korn-Shell, enter the following:

set JREHOME=/directory_containing_JDK_131
export JREHOME

Setting Up JREHOME on Windows NT
To set up JREHOME on Windows NT operating systems, use a MS-DOS prompt to 
enter the following command:

set JREHOME=C:\directory_containing_JDK_131

Once the Migration Tool is installed, you must set up the appropriate plug-in for 
your source e-mail system.

Setting Up the Oracle eMail Server Plug-In
If your source e-mail system is Oracle eMail Server, you must provide domain 
configuration name (DCN) and node information to the 
ES52Plugin.properties file, located in the Migration Tool bin directory, as 
follows:

DCN Specification
Provide one line per source domain. The entry must indicate the domain’s DCN and 
be in the form

oracle.mail.migration.plugin.es52.dcn.domain_name=hostname:port:SID:password
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For example, if the source domain is oracle.com and the SID for the DCN is db1, 
which runs on host h1 on port 1521, and the oo account password is oo, the DCN 
entry is as follows:

oracle.mail.migration.plugin.es52.dcn.oracle.com=h1:1521:db1:oo

Nodes Specification
Provide one line per source node, in the form

oracle.mail.migration.plugin.es52.node.node_name=hostname:port:SID:password

For example, if the source node is ESNODE and the SID for the node is db1, which 
runs on host h1 on port 1521, and the oo account password is oo, the node entry is 
as follows:

oracle.mail.migration.plugin.es52.node.ESNODE=h1:1521:db1:oo

Preparing for a Microsoft Exchange Migration
If your source e-mail system is Microsoft Exchange 5.0 or 5.5, you must perform the 
following tasks:

■ Creating an Administrator Profile Using Microsoft Outlook

■ Ensuring that the MAPI Spooler Process is Running

■ Using Statistics Task to Estimate Disk Space Requirements (Optional)

Creating an Administrator Profile Using Microsoft Outlook
If your source e-mail system is Microsoft Exchange, perform the following steps on 
the machine on which the source e-mail system is installed to create an 
administrator profile:

1. Ensure that Microsoft Outlook is installed on the machine and is operating 
correctly.

2. Create a profile using Microsoft Outlook.

1. Select Start > Settings > Control Panel from the Windows NT task bar.

2. Double-click the Mail icon.

3. Click Show Profiles... > Add....

4. Select Microsoft Exchange Server and enter a name in the Profile Name 
field. Click Next.
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5. Enter the name of the server in the Microsoft Exchange Server field.

6. In the Mailbox field, enter the name of an administrator.

3. Enter the profile information into the es_msplugin.ini file, which is 
available in the Migration Tool config directory. The format of the file is as 
follows:

profile_name=profile_name
password=password

For example, if the profile name is admin and the password is secret, the 
format of the file is:

profile_name=admin
password=secret

Ensuring that the MAPI Spooler Process is Running
If Microsoft Exchange is the source e-mail system, the MAPI spooler process must 
be running on the source system in order to extract the various files and perform 
routing.

To ensure that the MAPISP32.exe MAPI spooler process is running, bring up the 
Windows NT Task Manager. If the process is running, it appears in the list of 
processes.

To start the MAPI spooler process, double-click the executable in Windows 
Explorer.

Using Statistics Task to Estimate Disk Space Requirements (Optional)
To use Statistics Task to estimate disk space requirements, run it on the machine on 
which Microsoft Exchange is installed.

To run Statistics Task, enter the following command using the Windows NT 
command line:

msplugin.exe statistics_file=file_name user=user@domain

Note: If you do not have the MAPI spooler process, you can 
obtain the executable from Microsoft’s Platform SDK that comes 
with the Microsoft Developer Network (MSDN) collection. Install 
the Platform SDK released April, 2000, or later.
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Task 1: Starting the Migration Tool
To start the Migration Tool on UNIX operating systems, run the migrate.sh 
script, located in the Migration Tool bin directory, by entering the following 
commands:

cd bin
./migrate.sh

To start the Migration Tool on Windows NT operating systems, double-click the 
migrate.cmd file, located in the Migration Tool bin directory, or enter the 
following commands:

C:\> cd bin
C:\> .\migrate.cmd

The Migration Repository Login screen displays, shown in Figure 3–1.

This section contains the following topics:

■ Starting Multiple Instances of the Migration Tool

■ Configuring Migration Tool Parameters

Starting Multiple Instances of the Migration Tool
Multiple instances of the Migration Tool can be started if a situation warrants the 
use of multiple instances, as is the case in the following situations:

■ You can use multiple instances of the Migration Tool on one node to migrate 
more users concurrently

■ You can use multiple instances of the Migration Tool to connect to many nodes 
to migrate several nodes in a multi-node setup

To start multiple instances of the Migration Tool, edit the following parameter 
located in the migrate.sh file:

-Doracle.mail.migration.migrate.instance=unique_instance_name

For example, add the following two parameters to the migrate.sh file to start two 
different instances on UNIX:

Note: The user@domain can be any user on the Microsoft 
Exchange Server, not just an administrator.
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-Doracle.mail.migration.migrate.instance=inst1
-Doracle.mail.migration.migrate.instance=inst2

Configuring Migration Tool Parameters
By editing parameters located in either the migrate.sh (on UNIX) or 
migrate.cmd (on Windows NT) file, you can do the following:

■ Specify the number of connections in a pool created by each instance of the 
Migration Tool

■ Specify a particular instance of the Migration Tool by name

■ Set the Migration Tool to communicate to the source or target IMAP servers 
through a port number different from the default

■ Choose how the Migration Tool migrates messages to the target Oracle Email 
system

■ Disable message sharing for two-phase migration

Following are instructions for configuring Migration Tool parameters:

■ Every instance of the Migration Tool creates a pool of connections to the 
database. You can specify the minimum and maximum numbers of connections 
by editing the following parameters:

-Doracle.mail.migration.util.dbcache.min=1
-Doracle.mail.migration.util.dbcache.max=2

The values shown are default values.

Notes:

■ To recover a failed Migration Tool instance, restart it with
-Doracle.mail.migration.migrate.instance=unique
_instance_name, using the name of the failed instance. Users 
and batches that were migrating at the time of instance failure 
show the status failed. If more than one instance fails, they 
must all be re-run for complete recovery.

■ When more than one Migration Tool instance runs against a 
single repository, each instance picks up users independently.
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■ If you plan to run more than one instance of the Migration Tool, you can name 
each instance, uniquely, by editing the following parameter:

-Doracle.mail.migration.migrate.instance=instance_name

The default value of instance_name is default. The instance name can also 
be passed as a command line parameter to migrate.sh or migrate.cmd.

■ By default, the Migration Tool makes IMAP connections through port 143. If 
either the source or target IMAP server is set to a port other than 143, you can 
change it by editing the following parameters:

-Dmail.imap.port.source=port_number
-Dmail.imap.port.target=port_number

■ Either Java Mail API (JMA) or Oracle Java Mail API (OJMA) can be used to 
append messages to the Oracle Collaboration Suite e-mail system.

When JMA is used, the IMAP server uses an append command to append the 
messages to the target folders. When OJMA is used, the Migration Tool 
bypasses the IMAP server and creates the message in the Oracle Collaboration 
Suite mail database.

To use OJMA, define the following parameter:

-Doracle.mail.migration.migrate.jmatype=oracle

Following is an example of a JRE command to run an instance of the Migration Tool 
called myhost:1 with 1 GB heap and 50 database connections, using OJMA:

Notes:

■ Oracle Corporation recommends setting the maximum value to 
N, where N is the number of users migrating concurrently.

■ If extra connections are needed after the maximum limit is 
reached, the Migration Tool still opens connections to the 
database. The extra connections immediately close when they 
are no longer required. 

Note: If OJMA is used, target passwords need not be specified.
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$JRE -Xms1024m -Xmx1024m                                      
-Doracle.mail.migration.migrate.instance=myhost:1                                       
-Doracle.mail.migration.util.dbcache.max=50                                       
-Doracle.mail.migration.migrate.jmatype=oracle                                       
oracle.mail.migration.migrate.Migrate

Once the parameters are configured, you can start a particular instance of the 
Migration Tool by entering the following command:

migrate.sh instance_name (on UNIX)

or

C:\migration\bin\> migrate instance_name (on Windows NT)

Task 2: Logging In to the Migration Repository
The Migration Tool creates a repository under the es_mail user schema on the 
Oracle Email database. If a repository already exists, the Migration Tool reuses it.

Figure 3–1 Migration Repository Login Screen

Specify the following information to log in to the migration repository:

■ Password: The default password for the es_mail user is es.

■ Host: Enter the host name of the machine on which the source e-mail server is 
installed.
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■ Port: Enter the port number on which the Oracle Net Services listener is 
running. The default port number 1521. If you use a different port number, 
enter the number.

■ Service Name: Enter the SID where Oracle Collaboration Suite is installed.

After you enter the required information, click OK.

The Oracle Email Migration Tool screen displays.

Task 3: Setting Up a Migration Session
The Migration Setup Wizard collects details for the source and target domains; 
information for setting specific migration options; and notification of successful 
migration.

Select Tools > Migration Setup from the Migration Tool menu bar to start the 
Migration Setup Wizard and display the Welcome screen.

The following Migration Setup Wizard steps are described in this section:

■ Step 1: Specifying Mail System Objects

■ Step 2: Specifying Migration Options

■ Step 3: Specifying Notifications

■ Step 4: Specifying Mail Services

■ Step 5: Specifying Source Directory Server Parameters

■ Step 6: Specifying Target Directory Server Parameters

■ Step 7: Specifying LDAP Attribute Mapping

■ Step 8: Specifying New Account User Names

■ Modifying Migration Parameters

Click Next to display the Mail System Objects screen, shown in Figure 3–2. 

Note: All of the following steps are not required. The number of 
required steps is determined by choices made in Step 1.
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Step 1: Specifying Mail System Objects

Figure 3–2 Mail System Objects Screen

Specify the following information in the Mail System Objects screen:

■ Select the source e-mail system from the Select source mail system drop-down 
list.

■ Select each of the objects you want to migrate. Do not select an object if:

– It does not exist on the source e-mail server

– You do not want to migrate the object

After you finish entering the information, click Next to display the Migration 
Options screen, shown in Figure 3–3.
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Step 2: Specifying Migration Options

Figure 3–3 Migration Options Screen

Specify the following information in the Migration Options screen:

■ Select the number of users you want to migrate concurrently: Enter the 
number of users to be migrated concurrently by the Migration Tool.

The number you choose here specifies the number of reader threads reading 
from an IMAP source. This number is the upward limit of users that can be 
migrated at the same time. For example, if you select 100 as the number of users 
you want to migrate concurrently, 100 users are migrated concurrently at any 
one time during the migration process.

When you create batches for migration, the number of users in a batch is 
mutually exclusive of the number of users migrating concurrently. For example, 
if you create a batch of 500 users and select 100 as the number of users 
migrating concurrently, at most, 100 users at a time are migrated out of the 
batch of 500.



Task 3: Setting Up a Migration Session

3-14 Oracle Email Migration Tool Guide

The number of concurrently migrating users you choose depends upon the 
resources at your disposal. The size of the number will greatly affect the speed 
and efficiency with which the Migration Tool performs its tasks, such that the 
larger the number the more resources will be consumed.

■ In the Account Migration section, choose as your information source either 
LDAP Server or User Profiles File.

– If base accounts have not been created on the target e-mail system, check 
the Create Base Accounts box

– Specify User Quota (in MB) by entering a number in the adjacent field

■ In the Mail Migration section, select whether you want to perform an 
IMAP-based or MBOX-based migration

– IMAP-based: If your source e-mail system supports IMAP, the Migration 
Tool extracts the message information from the source e-mail system and 
places it directly into the target e-mail system

– MBOX-based: If your source e-mail system does not support IMAP, as is 
the case with Microsoft Exchange 5.0, choose this option. Select the 
Generate Mbox box and use the Browse button to specify the MBOX 
Directory Path to where the MBOX files will be created.

Although the MBOX option is chosen, the Migration Tool does not 
immediately extract the file to the target disk. Instead, the Migration Tool 
assumes that the extracted files are already on the disk in the specified 
location.

See Also:

■ Oracle Collaboration Suite Release Notes for information about the 
number of users to migrate concurrently

■ "Creating Batches" on page 3-32 for more information about 
batches

Note: The user quota is applied system wide.

Note: The Oracle eMail Server 5.2 Splug-in packaged with this 
release of the Migration Tool does not generate MBOX files.



Task 3: Setting Up a Migration Session

Migration Tasks 3-15

This feature is useful for extracting MBOX files from a Microsoft Exchange 
system, moving them to an intermediate store on another machine, and 
then loading the file into the target Oracle Email server.

– Select the Enable Routing box to enable routing of mail to the new user 
accounts.

■ In the Shared Folder Migration section, enter the folder owner’s source e-mail 
address.

When you finish entering the information, click Next to display the Notification 
screen, shown in Figure 3–4.

Notes:

■ MBOX is a common file-based mailstore format. The Migration 
Tool imports the information into the target e-mail system from 
the intermediate store.

■ There must be sufficient space on the target disk to store all of 
the users’ e-mail being migrated.

See Also: "Viewing Log Files" on page 2-14 for information on 
viewing the logs associated with MBOX file generation

Notes:

■ If your source e-mail system is Microsoft Exchange and you 
select Enable Routing, a rule is created on the Microsoft 
Exchange server during each user migration to forward a copy 
of all future messages to the target e-mail system.

■ If you choose to run a two-phase migration, do not select 
Enable Routing.

See Also: "Performing a Two-Phase Migration" on page 3-29 for 
more information about two-phase migration
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Step 3: Specifying Notifications

Figure 3–4 Notification Screen

Notifications are e-mail messages that inform users about migration events.

In the Notification section, select either New Account Details, Migration Report, 
or both.

■ When New Account Details is selected, after the account for the user is created 
on the target e-mail server, an e-mail is sent to the user’s old e-mail account 

Note: If you choose to run a two-phase migration, do not select 
either New Account Details or Migration Report.

See Also: "Performing a Two-Phase Migration" on page 3-29 for 
more information about two-phase migration
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notifying the user of their new user name, password, and IMAP and SMTP host 
names.

Click the Customize button to add header and footer notes to the notification.

■ When Migration Report is selected, the Migration Report section becomes 
active. You can choose to send an e-mail to either the user’s target account, the 
administrator, or both, notifying them that the migration is complete and that 
the user can begin using the new account.

If you choose to send a migration report to the administrator, enter their target 
user ID in the Administrator Email Address field.

Click the Customize button to add header and footer notes to the notification.

■ Select the Verify Migration box to attach a verification report to the migration 
report at the end of every migration.

When this option is selected, the Migration Tool compares the SMTP message 
ID of every message that is present on the target account with the source 
account. A report is generated from this comparison and is sent as part of the 
Migration Report.

■ You can set a Failed Message Limit by entering a number in the adjacent field. 
If the number of failed messages exceeds the number you enter, migration 
reports are delivered to the administrator, only.

When you finish entering the information, click Next to display the Mail Services 
screen, shown in Figure 3–5.

See Also: "Verifying Migration" on page 3-38 for more 
information about migration verification
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Step 4: Specifying Mail Services 

Figure 3–5 Mail Services Screen

Specify the following in the Mail Services screen:

■ In the Oracle eMail Server Mail Store section, enter the distinguished name 
(DN) of the target mail store in the associated field.

■ In the Source and Target Domains section, enter the following:

– Source Domain: Enter the source domain name

– Target Domain: Enter the target domain name to which the source domain 
maps

Note: Depending on your selections in the previous steps, the 
following text boxes are enabled on an as-needed basis.
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The data that belongs to a source domain is created on the target domain to 
which this source domain is mapped. For example, all objects belonging to 
both us.oracle.com and uk.oracle.com are created under 
oracle.com.

– Source IMAP Host: Enter the source IMAP host name (if you selected the 
MBOX based migration option in the previous step, this field does not 
appear)

– Target IMAP Host: Enter the target IMAP host name

– Source LDAP DN: Enter the LDAP DN for users on the source domain. If 
you have more than one domain, enter the LDAP DNs for all the domains. 
The Migration Tool looks for source account entries under the DN of the 
LDAP. Each domain has a separate DN.

– Target LDAP DN: Enter the LDAP DN for the target Oracle Internet 
Directory on which all users of this domain are created, in the format 
dc=oracle,dc=com, for a domain called oracle.com. The Migration 
Tool creates base account entries under the DN of the LDAP entry. Each 
domain has a separate DN.

– Target SMTP Host: Enter the SMTP host of the target domain which listens 
for e-mail

– Click More to enter more domains

When you finish entering the information, click Next to display the Source 
Directory Server screen, shown in Figure 3–6.

See Also: Your LDAP  server documentation for information 
about DN representation

Note: The Target SMTP Host field will only be active when you 
choose to send out migration notifications or have the Migration 
Tool create routing rules.
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Step 5: Specifying Source Directory Server Parameters 

Figure 3–6 Source Directory Server Screen

Specify the following source LDAP server information in the Source Directory 
Server screen:

■ Host Name: Enter the host name of the machine on which the source directory 
server is running

■ Port: Enter the port number on which the source directory server is listening

The default port number for LDAP is 389. Update the port number if your port 
number is different.

■ Directory Manager DN: Enter the directory manager distinguished name

■ Directory Manager Password: Enter the directory manager password

Leave the Directory Manager DN and the Directory Manager Password fields 
empty if the source LDAP server supports anonymous login.
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■ Object class of e-mail user: Enter the object class that identifies the schema of 
an e-mail user on the source LDAP server

When you finish entering the information, click Next to display the Target Directory 
Server screen, shown in Figure 3–7.

Step 6: Specifying Target Directory Server Parameters 

Figure 3–7 Target Directory Server Screen

Specify the following target Oracle Internet Directory information in the Target 
Directory Server screen:

■ Host Name: Enter the host name of the machine on which the target directory 
server is running

■ Port: Enter the port number on which the target directory server is listening

See Also: Oracle Email Administrator’s Guide for more information 
about schema
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The default port number for LDAP is 389. Update the port number if your port 
number is different.

■ Directory Manager DN: Enter the directory manager distinguished name

■ Directory Manager Password: Enter the directory manager password

When you finish entering the information, click Next to display the Username 
Generation screen shown in Figure 3–9.

Step 7: Specifying LDAP Attribute Mapping

Figure 3–8 LDAP Schema Mapping Screen

Note: Depending upon choices you made in previous steps, the 
next screen to display is the LDAP Schema Mapping screen, shown 
in Figure 3–8.
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On Oracle Email, an e-mail account is described by the orclperson object class. 
This object class has some mandatory attributes you must map to source directory 
attributes. These mandatory attributes include:

■ cn: Common Name

■ sn: Last Name

Mandatory Attributes: Click the source attribute on the right to display a list of 
mapping choices and select the mapping that you want to update the source 
attribute.

Non-Mandatory Attributes: Attributes that are not mandatory on the target Oracle 
Internet Directory have the option No Mapping displayed in the right column. 
Click the drop-down list to display a list of attribute choices to which to map if you 
want to map a non-mandatory attribute.

When you finish entering the information, click Next to display the Username 
Generation screen, shown in Figure 3–9.

Note: You need only map these attributes once, because the 
Migration Tool saves the values for the subsequent batches.
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Step 8: Specifying New Account User Names

Figure 3–9 Username Generation Screen

Specify the following information in the Username Generation screen:

To generate new account user names, select one of the following choices from the 
User Naming section:

■ Retain old user names: Specifies that the target user names remain the same as 
the source user names

■ Construct new user names: Specifies that the Migration Tool generates the 
target user names

If you choose to have the Migration Tool construct new user names, you must 
also supply the rules for user name generation in the New User Name 
Construction section.

When supplying rules for new user name construction, you can choose to retain 
the first, middle, or last names, or any combination of the three. Select the 
appropriate Yes button to retain any of the three names.
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You can also retain only part of a name by selecting the Partial button. Specify 
the number of characters you want to use in the Number of characters to retain 
field beneath each name.

You must also choose a separator character. To select a separator character, click 
the Separate names with drop-down list.

When you finish entering the information, click Next. The Summary screen 
displays. Click Finish to quit the Migration Setup Wizard and display the Oracle 
Email Migration Tool screen.

Resolving Account Name Conflicts
If the Migration Tool detects any duplicate target user names (also called name 
conflicts) when creating accounts in the target Oracle Internet Directory, it logs an 
error and does not create the duplicate account.

Duplicate target user name errors (name conflict errors) can only be avoided if user 
name generation rules are chosen so that unique target user names are generated.

To resolve name conflicts, perform the following steps:

1. Manually create the user with a unique name in Oracle Email.

2. Select Tools > Modify User Details to edit the information for that user.

3. Update the user’s status to Migrate User Data.

When all accounts have been successfully created, proceed to creating batches and 
migrating user data.

Notes:

■ If a name is disabled, it was not mapped in the LDAP Schema 
Mapping screen.

■ The values for first name, middle name, and last name are 
picked up from the source LDAP attributes that map to the 
given name, middle name, and surname orclperson 
attributes. You must provide this mapping in the LDAP 
Attribute Mapping screen.

■ Target user names, if specified in the user-list, are used in all 
cases.
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Modifying Migration Parameters
Any changes you make take effect after you cancel and restart the migration.

You cannot modify migration parameters during the migration.

To modify migration parameters, do the following:

1. Select Tools > Modify Migration Parameters from the Migration Tool menu 
bar. The Modify Migration Parameters screen displays, as shown in Figure 3–10.

See Also:

■ "Creating Batches" on page 3-32

■ "Task 11: Migrating Data" on page 3-36

Note: If two or more instances of the Migration Tool are running 
against the same repository, all instances except one must be shut 
down before modifications to the migration parameters can 
proceed.
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Figure 3–10 Modify Migration Parameters Screen

2. Modify the parameters.

3. Click OK.

Task 4: Migrating Users to Oracle Email
To migrate account information from the source directory server to Oracle Email, do 
the following:

1. Select Extract > Users from the Migration Tool menu bar to generate 
users.xml.

Note: If you selected User Profiles File from the Migration 
Options Screen, select Extract > User Profiles.
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2. View the text.log file located in the log/migration/uniquenumber 
directory. Any errors that occur during account migration are logged in the 
text.log file as administrator error messages.

3. Select Tools > Load Users from the Migration Tool menu bar to load 
users.xml into the repository.

4. Select Migrate > Create Users on Oracle from the Migration Tool menu bar to 
create user accounts in the target Oracle Internet Directory.

5. View the text.log file located in the log/migration/uniquenumber 
directory. Any errors that occur during account migration are logged in the 
text.log file as administrator error messages.

If a user’s data in the user-list file causes account migration of this user to fail, you 
can modify the user’s details and attempt to remigrate the batch after editing.

To modify user details, do the following:

1. Select Tools > Modify User Details from the Migration Tool menu bar. The 
Modify User Details screen displays, shown in Figure 3–11.

See Also:

■ "Overview of the Oracle Email Migration Tool Screen" on 
page 2-6 for information about the location of the users.xml 
file

■ Appendix A, "Plug-in Generated File Formats" for more 
information about user profile file formats

See Also: Oracle Collaboration Suite Administrator’s Guide for 
descriptions of error messages

Note: You can also select a user from the directory tree, select 
Tools > Modify User Details, and proceed with modifying the 
user’s details.
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Figure 3–11 Modify User Details Screen

2. Select the user’s source domain from the Domain drop-down list.

3. Enter the source user name in the Userid field.

4. Click Search to populate the fields with the user's information.

5. Edit the field entries.

6. Update the migration status by choosing from the list of choices in the Status 
drop-down list.

7. Click OK.

Performing a Two-Phase Migration
Because migration of user accounts and messages involves transferring large 
amounts of data and is, therefore, time consuming, users must be transferred from 
the old system to the new in the least possible amount of time.

The migration tool provides a two-phase migration option to achieve these 
conflicting goals that transfers messages from the old system to the new Oracle 
system in two phases.
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This section contains the following topics:

■ Phase I: Pre-Migration

■ Phase II: User Migration

Phase I: Pre-Migration
All users’ messages from the source system are written into into the target Oracle 
Email system. User accounts, however, are not actually populated with messages, 
nor are their folders created. In this phase all the message bodies will be transferred 
into the Oracle Email system. This is typically done in the background over several 
days while users continue to use their old accounts.

To start pre-migration, do the following:

1. Ensure that user accounts have been created on the target Oracle Email system.

2. Ensure that message routing has been disabled.

3. Select Migrate > Pre-Migrate User Data from the Migration Tool menu bar.

Phase II: User Migration
In Phase II, the Migration Tool takes advantage of the message sharing capability of 
Oracle Email to quickly populate users’ folders with the messages that were 
transferred in the first phase.

This phase typically involves only minimal housekeeping updates to the e-mail 
store and folder creation, and can be done over a weekend. During Phase II, the 
following operations are performed:

■ Any new messages that users receive between Phase I and Phase II are 
transferred to the target user account

■ Any messages that users delete in the interim will not appear in the target 
users’ accounts

■ Any new folders that users create in the interim are transferred to the target 
users’ account

■ Any folders that users have deleted in the interim will not appear in the target 
users’ account

See Also: "Step 2: Specifying Migration Options" on page 3-13 for 
more information about message routing
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Follow the procedures in "Task 11: Migrating Data" on page 3-36 to perform the 
Phase II of migration.

Task 5: Extracting Mail System Objects from the Source System
1. If you chose to migrate shared folders, select Extract > Shared folders from the 

Migration Tool menu bar to generate the shared_folders.ldif file in the 
files directory.

2. If you chose to migrate public aliases, select Extract > Public aliases from the 
Migration Tool menu bar to generate the public_aliases.ldif file in the 
files directory.

3. If you chose to migrate distribution lists, select Extract > Distribution lists from 
the Migration Tool menu bar to generate the distribution_lists.ldif file 
in the files directory.

4. View the text.log file located in the log/migration/uniquenumber 
directory. Any errors that occur during mail system object extraction are logged 
in the text.log file as administrator error messages.

Task 6: Batching
Once users are created, you must group them into batches for migration.

This section contains the following topics:

■ Creating Batches

■ Viewing Users in a Batch

Notes:

■ For best results Phase II should be performed as quickly as 
possible after Phase I is complete.

■ When you perform a two-phase migration, all batches will be 
migrated during both phases. It is not possible to selectively 
migrate specific batches during two-phase migration.

■ Phase II of the migration can be performed at any time because 
it is the typical migration approach.
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Creating Batches
Using the Migration Tool, you can create a batch either by designating the number 
of users for each batch or by creating a custom batch.

Batch creation is done on a domain basis. 

To create a batch by domain, do the following:

1. Expand the Migration View node on the directory tree on the left side of the 
Migration Tool screen.

2. Select the appropriate domain.

3. Select Batch > Create Batches. The Create Batches screen displays, as shown in 
Figure 3–12.

Figure 3–12 Create Batches Screen

4. Create batches using one of the following methods:

■ Select Number of users per batch and enter the number of users you want 
in each batch in the adjacent field. For example, if you have 100 users and 
specify 5 users in each batch, 20 batches are created.

■ Select Specify users for batch to create a custom batch. Enter the source 
user names for the custom batch. If you need to enter more user names, 
click More for more fields.
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After you create the batches, you can view them by expanding the domain node on 
the Migration Tool screen to display all the batches in the domain.

Viewing Users in a Batch
To view users in a batch, expand the domain node and the batch node to view the 
users in the batch, as shown in Figure 2–5, "Migration Tool Screen with User 
Information Displayed".

Task 7: Migrating Shared Folders
Prior to migrating shared folders, ensure that the following tasks are complete:

■ All user accounts have been migrated

■ You have generated the shared folders file

To migrate shared folders, do the following:

1. Select Migrate > Migrate Shared Folders from the Migration Tool menu bar to 
create the shared folders on the target e-mail server. The Shared Folder 
Migration Status screen displays.

2. When 100% displays, indicating the migration is complete, click OK.

3. View the text.log file located in the log/migration/uniquenumber 
directory. Any errors that occur during shared folder migration are logged in 
the text.log file as administrator error messages.

To cancel migration of shared folders, click Cancel on the status dialog that displays 
when you start to migrate mail objects.

See Also: "Task 11: Migrating Data" on page 3-36 for information 
about scheduling batches for migration

See Also: "Task 5: Extracting Mail System Objects from the Source 
System" on page 3-31 to generate the shared folder file

See Also: Oracle9iAS Unified Messaging Administrator’s Guide 
for descriptions of error messages
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Task 8: Migrating Public Aliases
Prior to migrating public aliases, ensure that the following tasks are complete:

■ All user accounts have been migrated

■ You have generated the public aliases file

To migrate public aliases, do the following:

1. Select Migrate > Migrate Public Aliases from the Migration Tool menu bar to 
create the public aliases on the target e-mail server. The Public Alias Migration 
Status screen displays.

2. When 100% displays, indicating the migration is complete, click OK.

3. View the text.log file located in the log/migration/uniquenumber 
directory. Any errors that occur during public aliases migration are logged in 
the text.log file as administrator error messages.

To cancel migration of public aliases, click Cancel on the status dialog that displays 
when you start to migrate mail objects.

Note: If you cancel migration of shared folders, rollback does not 
occur and you can safely restart migration. The e-mail objects that 
were created before you canceled migration are not re-created when 
migration is recommenced. Migration continues from the point 
where it was canceled.

See Also: "Task 5: Extracting Mail System Objects from the Source 
System" on page 3-31 to generate the public aliases file

See Also: Oracle9iAS Unified Messaging Administrator’s Guide 
for descriptions of error messages

Note: If you cancel migration of public aliases, rollback does not 
occur and you can safely restart migration. The e-mail objects that 
were created before you canceled migration are not recreated when 
migration is recommenced. Migration continues from the point 
where it was canceled.
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Task 9: Migrating Distribution Lists
Prior to migrating distribution lists, ensure that the following tasks are complete:

■ All user accounts have been migrated

■ You have generated the distribution lists file

There are two phases to distribution list migration:

1. All distribution lists are created.

2. The distribution lists are populated with users.

The status bar displays immediately, and shows progress when distribution lists are 
being populated with users. For example, when the status bar shows that 50% of the 
distribution lists have been migrated, it means all of the distribution lists have been 
created and 50% of the distribution lists have been populated with users.

To migrate distribution lists, do the following:

1. Select Migrate > Migrate Distribution Lists from the Migration Tool menu bar 
to create the distribution lists on the target e-mail server. The Distribution List 
Migration Status screen displays.

2. When 100% displays, indicating the migration is complete, click OK.

3. View the text.log file located in the log/migration/uniquenumber 
directory. Any errors that occur during distribution list migration are logged in 
the text.log file as administrator error messages.

To cancel migration of distribution lists, click Cancel on the status dialog that 
displays when you start to migrate mail objects.

See Also: "Task 5: Extracting Mail System Objects from the Source 
System" on page 3-31 to generate the distribution lists file

See Also: Oracle9iAS Unified Messaging Administrator’s Guide 
for descriptions of error messages

Note: If you cancel migration of distribution lists, rollback does 
not occur and you can safely restart migration. The e-mail objects 
that were created before you canceled migration will not be 
recreated when migration is recommenced. Migration continues 
from the point where it was canceled.
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Task 10: Migrating WebMail Address Books

The Migration Tool can migrate the private address books created by users using 
their Oracle eMail Server 5.2.1 WebMail clients. Migration of the WebMail address 
book of each user involves migrating both the private aliases and private 
distribution lists that users have.

Prior to migrating address books, ensure that all user accounts have been migrated.

To migrate WebMail address books, do the following:

1. Select Migrate > Migrate Address Book from the Migration Tool menu bar. The 
Address Book Migration Status screen displays. 

2. When 100% displays, indicating the migration is complete, click OK.

3. View the text.log file located in the log/migration/uniquenumber 
directory. Any errors that occur during address book migration are logged in 
the text.log file as administrator error messages.

To cancel migration of address books, click Cancel on the status dialog that displays 
when you start to migrate address books.

Task 11: Migrating Data
Prior to migrating data you must schedule your batches for migration.

To schedule a start time for batch migration, do the following:

Note: WebMail Address Book migration is available only for 
Oracle eMail Server to Oracle Email migrations. This migration can 
be run only for users using the 5.2.1 WebMail client.

See Also: Oracle9iAS Unified Messaging Administrator’s Guide 
for descriptions of error messages

Note: If you cancel migration of address books, rollback does not 
occur and you can safely restart migration. The address book 
objects that were created before you canceled migration are not 
recreated when migration is recommenced. Migration continues 
from the point where it was canceled.
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1. Select a batch from the directory tree in the Migration Tool screen (see 
Figure 2–4 on page 2-11).

2. In the Scheduled Start Time field, select either the date or the time and edit it 
by using the Up and Down arrows. The date is in MM/DD/YY format and the 
time is in HH:MM format.

3. After you complete your updates, click Schedule for the updated schedule to 
take effect.

To start data migration, select Migrate > Migrate User Data from the Migration 
Tool menu bar.

To cancel migration, select Migrate > Cancel Migration from the Migration Tool 
menu bar.

View the text.log file located in the log/migration/uniquenumber directory. 
Any errors that occur during data migration are logged in the text.log file .

Note: You can schedule multiple batches to migrate in parallel by 
scheduling them to start at the same time.

See Also: Figure 2–4, "Migration Tool Screen with Batch 
Information Displayed"

Note: Even if you do not make changes to the schedule, you must 
click Schedule for the batch to be scheduled. If you do not click 
Schedule, the users are not scheduled for migration.

Note: If a single user in a batch fails, the batch will be marked as 
failed. To reschedule the batch for migration, select the failed batch 
from the Migration Tool screen, edit the Scheduled Start Time field, 
and click Schedule. Once a batch is rescheduled, the users that 
failed are reverted to the pending state and the batch is picked up 
again for data migration when the scheduled migration time 
occurs. Only users that have failed to migrate are migrated. Users 
that have been successfully migrated will not be remigrated.
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Post-Migration Administrator Responsibilities
Upon completion of migration, the administrator must perform the following tasks:

■ Changing the MX Record

■ Verifying Migration

Changing the MX Record
You must change the mail exchanger (MX) record in order to redirect e-mail to the 
new system.

Verifying Migration
You can verify migration of individual users’ accounts and data using one of several 
methods of comparison. This helps the administrator to verify the validity of the 
overall migration, and is also helpful to support personnel when users complain of 
discrepencies in their accounts.

To access the Verification screen shown in Figure 3–13, select Tools > Verify New 
Accounts from the Migration Tool menu bar.

Notes:

■ The verifier can be used only for users who have successfully 
migrated.

■ The verifier is not available for MBOX-based migration.
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Figure 3–13 Verification Screen

1. Enter the user IDs of users you want to verify in the Users To Be Verified field.

You can populate the Users To Be Verified field using the search feature. The 
search feature enables you to search for specific users by entering user name, 
domain, or batch in the adjacent field. Click Search.

The results of your search display in the Search Results field. Select the users 
you want to verify and click the Right Arrow button to populate the Users To 
Be Verified field.

2. Select from one of the following verification options:

■ Message Count: Compares the message counts in the folders to verify that 
they match

■ Message IDs: Compares the SMTP message IDs to verify that they match

Note: Each option verifies that all folders in an individual user’s 
account have been created on the target e-mail system, and 
compares different message information between the source and 
target e-mail systems.
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■ Message Header: Compares the message headers to verify that they match

■ Entire Message: Compares the message bodies of every message to verify 
that they match

3. Enter the address of the recipient of the verification reports in the 
Administrator Email ID field.

Shutting Down Microsoft Exchange Servers
You can shut down the Microsoft Exchange servers upon completion of migration 
only after you determine that you no longer need routing rules set up on the source 
e-mail system.

In cases where you have multiple Microsoft Exchange servers, you can move users 
from whichever machine they reside, to one single machine as their data is migrated 
to Oracle Email.

Note: If you choose either the Message Header or Entire Message 
verification option while migration is proceeding, migration 
process is slowed considerably.

See Also: Microsoft Exchange documentation for information 
about moving users from one machine to another
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A
Plug-in Generated File Formats

In this appendix are the following sample LDIF and XML file formats:

■ User-List File Format (XML)

■ Distribution List File Format (LDIF)

■ Public Aliases File Format (LDIF)

■ Shared Folder File Format (LDIF)

■ Rules File Format (XML)
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User-List File Format (XML)
Following is the syntax of a user-list file in XML format:

?xml version="1.0" encoding="UTF-8" ?> 
<!ELEMENT userlist (user*)> 
<!ELEMENT user EMPTY> 
<!ATTLIST user sourceimapuserid CDATA #REQUIRED sourceimappasswd CDATA #IMPLIED
             sourceimapserver CDATA #IMPLIED targetimapuserid CDATA #IMPLIED
               targetimappasswd CDATA #IMPLIED targetimapserver CDATA #IMPLIED
             targetdomain CDATA #IMPLIED mailstore CDATA #IMPLIED
               quota CDATA #IMPLIED>

For IMAP-based migration, the sourceimapuserid and sourceimappasswd 
attributes are mandatory. For MBOX-based migration, only the 
sourceimapuserid attribute is mandatory.

Sample user-list file for two users:

<userlist> 
<user 
sourceimapuserid="TEST1" 
sourceimappasswd="WELCOME" 
/> 
<user 
sourceimapuserid="TEST2" 
sourceimappasswd="WELCOME" 
/> 
</userlist>

The values for all other attributes are provided using the Migration Setup Wizard.  
For any user, if the administrator does not want to use the default values, specific 
values can be provided using the specified format.

Distribution List File Format (LDIF)
The distribution list file that the plug-in generates is in the following format:

dn: cn= dl1
cn:dl1
objectclass:  top
objectclass: groupofuniquenames
objectclass:  orclMailGroup
orclmgprfc822mailmember: user1@acme.com
orclmgprfc822mailmember: user2@acme.com
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mail:dl1@acme.com
uniquemember: dl200@acme.com
uniquemember: dl300@acme.com
uniquemember: dl400@acme.com

dn: cn= dl2
cn:dl2
objectclass:  top
objectclass: groupofuniquenames
objectclass:  orclMailGroup
orclmgprfc822mailmember: user4@acme.com
orclmgprfc822mailmember: user3@acme.com
mail:dl2@acme.com
uniquemember: xd1500@acme.com
uniquemember: xd1400@acme.com

The mail attribute contains the fully qualified name of the distribution list. The 
Migration Tool expects the name in the format dlname@targetdomain.

The orclmgprfc822mailmember attribute is the fully qualified e-mail address of 
the user to whom this distribution list belongs. The Migration Tool expects the 
name in the format source_imap_userid@sourcedomain.

The uniqumember attribute contains the sub distribution lists of this distribution 
list. The Migration Tool expects the name in the format dlname@sourcedomain.

Public Aliases File Format (LDIF)
The public alias information that the plug-in generates is in the following format:

dn:cn=alias1
name:alias1@acme.com
cn:alias1
orclmailemail:user1@acme.com
objectclass:top
objectclass:orclMailAlias

dn:cn=alias2
name:alias2@acme.com
cn:alias3@acme.com
orclmailemail:user2@acme.com
objectclass:top
objectclass:orclMailAlias

dn:cn=alias3
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name:alias3@acme.com
cn:alias3
orclmailemail:user3@acme.com
objectclass:top
objectclass:orclMailAlias

The name attribute contains the fully qualified name of the alias. The Migration Tool 
expects the name in the format aliasname@sourcedomain.

The orclmailemail attribute is the fully qualified e-mail address of the user for 
whom this alias is created. The Migration Tool expects the name in the format 
source_imap_userid@sourcedomain.

Shared Folder File Format (LDIF)
The shared folder file generated by the plug-in contains information about shared 
folders that are being migrated.

dn: cn=/pubfol
objectclass: top
objectclass: orclMailFolder
orclmailaci: user2@acme.com a l r p d i w
orclmailaci: user4@acme.com l r p
owner: user1@acme.com
cn:/pubfol
orclIsSharedFolder: false

dn: cn=/shfol
objectclass: top
objectclass: orclMailFolder
orclmailaci: user2@acme.com a l r p d i w
orclmailaci: user4@acme.com l r p
owner: user1@acme.com
cn:/shfol
orclIsSharedFolder: true

The cn attribute contains the name of the shared folder. The Migration Tool expects 
the name in the format /foldername.

The orclmailaci attribute contains ACI information. The Migration Tool expects 
the user name of the ACI in the format source_imap_userid@sourcedomain.

The orclIsSharedFolder attribute has a false value if the folder is a public 
folder.
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The orclMailStore attribute contains the distinguished name of the target mail 
store on which the shared folder is to be created.

The owner attribute contains the fully qualified mail address of the owner of the 
shared folder. The Migration Tool expects the name in the format 
source_imap_userid@sourcedomain.

User Profile File Format (LDIF)
If your source directory information comes from user profile files, instead of an 
LDAP directory, use the following format:

dn: cn=user_given_name,dc=oracle,dc=com
cn: user_given_name
mail: username@acme.com
title:title
telephoneNumber:telephone_number
homePhone:telephone_number
sn:surname
st:state
physicalDeliveryOfficeName:physical_delivery_address_of_office
manager:user’s_manager
ou:organizational_unit
o:organization
secretary:name_of_secretary
postalAddress:postal_delivery_address

The only mandatory attributes are mail and sn. Mail is expected in the format 
sourceuserid@sourcedomain.

Rules File Format (XML)
A rule consists of two parts: a set of conditions to be met, and actions to be 
performed when at least one of the set of conditions is met. The set of conditions is 
evaluated until a true condition in the set is encountered. Rules are identified by 
their actions. If multiple actions are to be carried out when a certain condition is 
true, then multiple rules must be defined sharing the same set of conditions. 

A condition is a combination of simple clauses. A clause is a simple relational 
operation between a message attribute and a scalar constant value. For example, a 
clause can be "message size is greater than 10 Kb".

Condition evaluation is implemented as a short-circuit AND operation upon all 
clauses, which fails upon encountering the first failed clause. 
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A rule list is a list of rules that apply when a message is delivered to a user’s inbox. 
A rule begins with the tag <rule> and ends with the tag </rule>. A condition 
begins with the tag <condition>, as shown in the following example rule in XML 
format:

<account qualifiedName="user_rules" ownerType="user">
 <rulelist event ="deliver">
 <rule  visible= "yes" active= "yes" description = "exchusr1" >
   <condition>
    <attribute tag="rfc822from"/>
    <operator op="contains"/>
    <operand> EXCHUSR1 </operand>
   </condition>
  <action>
   <command  tag= "moveto"/>
   <parameter>/pvtfldr1 </parameter>
  </action>
 </rule>

 </rulelist> 
</account>

Following is the XML format for specifying a server-side rule:

<?xml version="1.0" encoding="UTF-8" ?>
<!-- an account contains multiple rulelists -->
<!ELEMENT account (rulelist*)>
<!ATTLIST account name NMTOKEN #REQUIRED
                  ownerType (user|system|domain) "user">
<!-- a rulelist is associated with an event and a list of rules -->
<!ELEMENT rulelist (rule+)>
<!ATTLIST rulelist event (relay|reception|deliver|flagchange|move|copy|
  queuing|expunge|expire) #REQUIRED>
<!-- a rule consists of an optional condition and a list of actions.  
     a rule can be visible, hidden, activated or disabled -->
<!ELEMENT rule (condition?, action+)>
<!ATTLIST rule visible (yes|no) "yes"
       active (yes|no) "yes"
       description CDATA #IMPLIED>
<!-- conditions are either attribute comparisons (leaf conditions),
     sub conditions (parenthesis) or external procedure calls -->
<!ELEMENT condition ((attribute, operator, operand*)
    |condition+|procCall|inBody)>
<!ATTLIST condition negation (yes|no) "no">
<!ATTLIST condition junction (and|or) "and">
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<!-- attributes are message properties, param is for extended header and flag-->
<!ELEMENT attribute EMPTY>
<!ATTLIST attribute name (rfc822from|rfc822to|rfc822cc|rfc822date|
                          rfc822subject|rfc822replyto|sendhost|sender|
                          recipients|message_id|receiveddate|
                          contenttype|charset|xpriority|messagesize|
                          xheader|folder|flag|overquota|rulestatus)
                          #REQUIRED
                    param CDATA #IMPLIED>
<!-- operators -->
<!ELEMENT operator EMPTY>
<!ATTLIST operator op (equal|greaterthan|lessthan|lessequal|
                       greaterequal|in|stringequal|isnull|
                       startswith|endswith|contains|between|istrue)  
                       #REQUIRED
                   caseSensitive (yes|no) "no">
<!-- operands custom data -->
<!ELEMENT operand (#PCDATA)>
<!-- procCall is external condition call -->
<!ELEMENT procCall (#PCDATA)>
<!-- inBody is content related match condition -->
<!ELEMENT inBody (#PCDATA)>
<!-- actions may have parameters-->
<!ELEMENT action (command, parameter*)>
<!ELEMENT command EMPTY>
<!ATTLIST command name (pass|reject|suspend|discard|forward|
                        bcc|moveto|copyto|setprop|notify|reply|
                        replyall|break|sign|verify|decrypt|
      encrypt|enqueue|call) #REQUIRED>
<!ELEMENT parameter (#PCDATA)>
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B
API Architecture

This appendix contains information about the architecture of an API that 
communicates with a third party plug-in.
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Any plug-in that is to work with the Migration Tool must support the following 
interface:

public interface PluginInterface
{

public boolean doTask(String taskName, String taskArgs[]) throws 
PluginException;
public String getVersion();
public void init() throws PluginException;
public void cleanUp();

}

The getVersion method must return the version number of the plug-in.

The init method must contain any initialization code.

The cleanUp method must contain any cleanup code. 

The Migration Tool passes a command string and an argument array to the doTask 
method. The values that the command string and argument array must contain for 
different commands are listed in Table B–1.

Table B–1 Parameter Values for doTask Method

Parameters for the doTask Method Operation

command = "User_list" 
arg[0]= "file=file_name"
arg[1]="domain=domain name"

The plug-in generates a user-list file for a 
specific domain in the specified file

command = "User_profiles"
arg[0]="file=file_name"
arg[1]="domain=domain_name"

The plug-in generates an LDIF file of all 
users on the source system

command = "Mbox_files"
arg[0] = "user=m_sourceuname"
arg[1] = "mbox_dir=m_mboxDir"

The plug-in generates an MBOX file for the 
user in the specified directory

command = "User_rules"
arg[0] = "user=sourceuname"
arg[1] = "dir=m_rulesDir"

The plug-in generates the rules XML file for 
the specified user in the specified rules 
directory

command = "Shared_folders"
arg[0] = "file=file_name"
arg[1] = "shared_folder_mbox_
dir=mboxdir"

The plug-in generates the shared folder file 
in the standard format in the specified file. 
MBOX files for the shared folder are 
generated in the
shared_folder_mbox_dir.
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Any developer writing a plug-in should ensure that the plug-in accepts the above 
set of parameters. Various parameters on the command line are separated by a 
single space.

command = "Distribution_lists"
arg[0] = "file=file_name"

The plug-in generates the distribution list 
file in the standard format in the specified 
file

command = "Public_aliases"
arg[0] = "file=file_name"

The plug-in generates the list of public 
aliases in the specified file in the standard 
format

Table B–1 Parameter Values for doTask Method

Parameters for the doTask Method Operation
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pre-migration, 3-2

anonymous login, 3-20
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non-mandatory, 3-23
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Migration Tool Screen with Batch Information 
Displayed, 2-11

scheduling, 3-36
viewing users in, 3-33

batching, 3-31

C
Cancel Migration menu option, 3-37
canceling migration

data, 3-37
distribution lists, 3-35, 3-36
public aliases, 3-34
shared folders, 3-33

character sets
supporting different, 2-5

concurrent number of users to migrate, 3-13
configuration planning, 2-4

conflicts, user names, 3-25
Create Users on Oracle, 3-28

D
data

migrating, 3-36
data migration, 3-36

canceling, 3-37
data migration, starting, 3-37
database connection pool

configuring, 3-8
DCN specification

setting up Oracle eMail Server plug-in, 3-4
setting up the Oracle eMail Server plug-in, 3-4

directory manager
distinguished name, 3-20, 3-22
password, 3-20, 3-22

distribution lists
migrating, 3-35

done, user state, 2-13
duplicate target user IDs, 3-25

E
e-mail notificaiton, 3-16
environment variable, setting JREHOME, 3-4

F
failed, user state, 2-13
format

public aliases file, A-3
rules file (XML), A-6
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guidelines, sizing, 2-4

H
host name

source directory server, 3-20
target directory server, 3-21

host, parameter, 3-10

I
IMAP

migration option, 3-14
IMAP based migration, 2-4
IMAP server configuration, 3-2
IMAP server port number

configuring, 3-9
IMAP to IMAP migration, 2-4
IMAP-based migration

about, 1-6
installation

about, 3-3
setting JREHOME, 3-4

instance name
configuring, 3-9

intermediate
storage of data, 2-4
store, 2-4

J
JREHOME, 3-4

L
LDAP Attribute Mapping screen, 3-22
log files

directory, 2-14
Migration_default.log, 2-14

viewing, 2-14
login, anonymous, 3-20

M
Mail Services screen, 3-18
mail system objects

extracting, 3-31
Mail System Objects screen, 3-12
MBOX based migration, 2-4
MBOX to IMAP migration, 2-4
MBOX-based migration, 1-4

about, 1-4
Microsoft Exchange

server
shutting down, 3-40

Migrate Distribution Lists, 3-35
Migrate Public Aliases, 3-34
Migrate User Data menu option, 3-37
migrating

accounts
discussion, 1-3
procedure, 3-27
See also task 5, migrating users from the source 

system, 3-27
address books, 3-36
data, 3-36
distribution lists, 3-35
number of users to migrate concurrently, 3-13
public aliases, 3-34
shared folders, 3-33
user migration states, 2-13

migration
about, 1-2
canceling

data, 3-37
distribution lists, 3-35, 3-36
public aliases, 3-34
shared folders, 3-33

choosing options, 2-4
IMAP to IMAP, 2-4
MBOX to IMAP, 2-4
process, 1-3
verifying, 3-38

Migration Options screen, 3-13
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migration parameters, modifying, 3-26
migration repository parameters, 3-10
Migration Setup Wizard

See also setup wizard steps
migration tasks

task 1, installing the Migration Tool, 3-3
task 10, migrating distribution lists, 3-35
task 11, migrating WebMail address books, 3-36
task 12, migrating data, 3-36
task 2, starting the Migration Tool, 3-7
task 3, logging in to the migration 

repository, 3-10
task 4, setting up a migration session, 3-11
task 5, migrating users from the source 

system, 3-27
task 6, extracting mail system objects from the 

source system, 3-31
task 7, batching, 3-31
task 8, migrating shared folders, 3-33
task 9, migrating public aliases, 3-34

Migration Tool
multiple instances, 3-7

starting, 3-7
overview of menu selections, 2-6
using, 2-5

migration tool
parameters

configuring, 3-8, 3-9
screen

menu selections, 2-6
Modify Migration Parameters screen, 3-27
Modify User Details, 2-8, 3-28
Modify User Details screen, 3-29
modifying migration parameters, 3-26
MX record, changing the, 3-38

N
namespace

changes, 3-25
conflicts, 3-25

New Account User Names screen, 3-24
nodes specification

setting up Oracle eMail Server plug-in, 3-5
setting up the Oracle eMail Server plug-in, 3-5

notification
specifying, 3-16

O
OJMA

defined, 3-9
optimizing performance, 2-13
Oracle eMail Server

plug-in
setting up, 3-4

DCN specification, 3-4

nodes specification, 3-5
Oracle eMail Server plug-in

setting up
DCN specification, 3-4
nodes specification, 3-5

P
parameters

configuring, 3-8, 3-9
migration repository, 3-10
migration, modifying, 3-26
source directory server, 3-20
source e-mail server, 3-20
target directory server, 3-21

pending, user state, 2-13
performance

optimizing, 2-13
tuning, 2-13

planning
configuration, 2-4
routing reconfiguration, 2-5

plug-in
defined, 1-2

plug-ins
deploying, 3-5

port
Oracle Net Services listener, 3-11
source directory server, 3-20
target directory server, 3-21

protocols
IMAP, 1-4, 3-14

public aliases
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file format, A-3
migrating, 3-34

R
read and write speeds, 2-13
routing reconfiguration planning, 2-5
rules file format (XML), A-6

S
scheduling batches, 3-36
service name, 3-11
setup wizard screens

LDAP Attribute Mapping screen, 3-22
Mail Services screen, 3-18
Mail System Objects screen, 3-12
Migration Options screen, 3-13
New Account User Names screen, 3-24
Specifying Source Directory Server Parameters 

screen, 3-20
Target Directory Server screen, 3-21

setup wizard steps
step 1, specifying mail system objects, 3-12
step 2, specifying migration options, 3-13
step 3, specifying mail services, 3-18
step 4, specifying source directory server 

parameters, 3-20
step 5, specifying target directory server 

parameters, 3-21
step 6, specifying LDAP attribute 

mapping, 3-22
step 7, specifying new account user names, 3-24

shared folders
migrating, 3-33

sizing guidelines, 2-4
source LDAP server

specifying information, 3-20
source user names, retaining, 3-24
specifying

source e-mail server parameters, 3-20
target directory server parameters, 3-21

Specifying Source Directory Server Parameters 
screen, 3-20

starting data migration, 3-37

states
user, 2-13

done, 2-13
failed, 2-13
migrating, 2-13
pending, 2-13

states, user, 2-13
statistics task

defined, 2-2
using, 3-6

storage of data, intermediate, 2-4
store, intermediate, 2-4
system requirements, 2-2

T
target

OID, 3-21
usernames, generating, 3-24

Target Directory Server screen, 3-21
target user IDs, duplicate, 3-25
tuning for performance, 2-13
two-phase migration

disabling message sharing, 3-8

U
user names

retaining source, 3-24
user states, 2-13
usernames

generating target, 3-24
using OJMA

configuring, 3-9

V
verifying migration, 3-38
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