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Getting Started with

Adobe Flash Builder 4

CONTENTS INCLUDE:
n	 About Adobe Flash Builder 4
n	 Create a Project
n	 Developing 
n	 Building
n	 Running and Debugging
n	 Testing and more...

Hot 
Tip

Flex® Builder™ is now Flash Builder
The previous version of Flash Builder 4 was Flex Builder 
3. Adobe changed the name for this release to avoid 
confusion between the open-source Flex framework and 
Flash Builder 4, which is a commercial IDE.

Adobe Flash Builder, part of the Adobe Flash Platform, is a 
multimedia platform that utilizes browser plug-ins to deliver 
rich content via the web.  With a market penetration over 
99% in most developed countries, it is a ubiquitous platform 
for developing rich content.  Adobe Flex is an open-source 
Software Development Kit (SDK) used to develop rich 
applications on the Flash platform.  Flex applications can also 
be delivered as applications that are installed locally using 
Adobe AIR®.

Flash Builder 4 is an Integrated Development Environment 
(IDE) from Adobe Systems Inc. for ActionScript® and Flex 
development. Flash Builder is built on top of Eclipse, an open 
source extensible development platform, and a popular Java 
IDE. Because it is built on Eclipse, Flash Builder 4 inherits 
an impressive list of plug-ins and is a familiar tool for many 
developers.

This Refcard outlines how to use Flash Builder to develop Flex 
applications, including creating new projects in Flash Builder, 
Developing, Building (compiling), Testing, and Debugging Flex 
applications. 

Flash Builder 4 is supported on Windows and Mac OS X, and 
can be installed as an Eclipse plug-in or as a standalone install. 

Hot 
Tip

Coexist
Flex Builder 3 and Flash Builder 4 can coexist on the same 
system. However, they cannot coexist as plug-ins in the 
same Eclipse install. If you have Flex Builder 3 installed as 
an Eclipse plug-in, you should uninstall it before installing 
the Flash Builder 4 plug-in, or install Flash Builder 4 
standalone.

Flash Builder 4 is a commercial product and must be purchased 
from Adobe (a 60-day free trial is available).Flash Builder 4 
pricing will be consistent with Flex Builder 3, with the Standard 
Edition available for $249 (USD) or $99 (USD) for an upgrade. 
The Professional Edition available for $699 (USD) or $299 
(USD) for an upgrade. The Standard Edition is available free 
for Education, and Volume and Government pricing are also 
available.

For additional information on the differences between Flex 
Builder 3 Standard and Professional, see Adobe’s Reasons to 

Buy Flex Builder 3: http://www.adobe.com/products/flex/updrade

Getting Flash Builder 4
Go to the Adobe download site - 
http://www.adobe.com/go/try_flashbuilder
Choose the download for your operating system from either 
the Standalone Installer or Plug-in for Eclipse sections.

For either the Standalone or Plug-in versions, the downloaded 
file is an installer.  For Windows, simply run the downloaded file 
(.exe).  For OS X, mount the DMG file and run the installer app 
inside the disk image.  The installers will launch a wizard with 
instructions on how to complete the installation.

Once installed, the standalone Flash Builder can be run 
from the installed location (Program Files on Windows or 
Applications on OS X), or the plug-in version can be run by 
launching Eclipse.

When Flash Builder is first launched, it prompts the user for a 
serial number, or you can elect to start a 60-day trial.  During 
the trial, it will display a dialog box that allows you to enter 
a serial number or continue with the trial each time it is 
launched.

CREATE A PROJECT

Flash Builder uses projects as the parent container for all 
development activities.  Before you start working, you must 
first create a new project.

® ™®

Hot 
Tip

Applications created by Adobe Flash Builder can be 
published in the browser using the Adobe Flash Player, and 
outside the browser using Adobe AIR.

brought to you by...
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Create a new project using the menu: File -> New -> Flex 
Project. This starts the New Flex Project wizard.

The first step requires that you specify a name for your project.  
You can also override the default location.  There are several 
other important choices on this first page:

Application Type
Flash Builder supports two applications types, Web and 
Desktop. Web projects create Flash .swf files that can be 
distributed via a web server and run within a client browser.  
Desktop projects create .air files that can be downloaded and 
installed as local applications.

Hot 
Tip

Sandbox
Applications that run within the browser are limited to 
a local sandbox.  They do not have access to the local 
computer’s file system and have limited network access.  
AIR applications have full local file system and 
network access.

Server Technology
Flash Builder 4 supports integration with several server 
technologies, including ASP.Net, ColdFusion, J2EE, and PHP.  
Selecting one of these options allows Flash Builder to provide 
automatic configuration for remote calls.  If an option other 
than None/Other is selected, additional information will be 
collected in step two.  The specific data needed is dependent 
on the selected technology. Flex can also interact with REST 
and SOAP services written in any technology.

The additional steps in the wizard allow for further 
customization of the project, but the default values are 
acceptable for most beginner projects.

Hot 
Tip

Component Sets
The Flex SDK provides a rich set of components useful for 
developing applications, including everything from Buttons 
and Labels to rich charting components.  The components 
in Flex 3 are called the MX components, while Flex 4 
introduces the Spark components.  Flex 4 projects will 
use a combination of these components. Flash Builder 4 
continues to work with the Flex 3 SDK and MX components.

DEVELOPING

When a project is created or opened, Flash Builder displays the 
main window, called the workbench.

Workbench
The workbench consists of a set of Views, Editors, and 
Toolbars.  Views provide visual access to some part of your 
project.  The initial views include the Package Explorer, Outline, 
Problems, and several others.  Editors allow you to edit the 
source files, and can be text based or visual.  Toolbars provide 
easy access to commonly used menu items.

Perspectives can be used to manage your workbench.  A 
perspective is a collection of views and toolbars appropriate 
for a certain activity.  Flash Builder provides two default 
perspectives, Flash and Flash Debug.  These perspectives open 
the appropriate Views and Toolbars for Development (Flash) or 
Debugging (Flash Debug).  You can modify these perspectives 
or define your own to customize the Flash Builder environment 
to your individual taste.

Hot 
Tip

Getting Started with Eclipse
Flash Builder 4 is built on Eclipse, and inherits many of its 
features and shortcuts.  For more information on Eclipse, 
please see the Getting Started with Eclipse Refcard. 
http://refcardz.dzone.com/refcardz/getting-started-eclipse

Building Flex Applications
Flex applications consist of two different types of source files. 
MXML files (.mxml) are XML files that allow you to arrange 
visual components, as well as include non-visual components 
and ActionScript code. ActionScript files (.as) contain 
ActionScript code (classes, interfaces, etc.). You can achieve 
the same functionality with either type of file, but they are 
tailored to different usages.

MXML files are ideal for visual components that contain small 
amounts of ActionScript code. ActionScript files are ideal for 
non-visual code, including model or service classes.

Flash Builder provides powerful editors for both types of 
source files.

Hot 
Tip

Adobe Flash Catalyst
Adobe Flash Catalyst is a tool that allows designers to 
easily create Flex applications from artwork created from 
the Adobe Creative Suite.  Flash Builder provides tools to 
import Adobe Flash Catalyst projects.  For more information 
on Catalyst:  https://www.adobe.com/go/catalyst

MXML 
MXML files can be edited in two modes, Source and Design. 
You can switch back and forth between these modes while 
editing an MXML source file. This makes it easy to manage the 
visual layout using the designer while switching to the source 
view to add ActionScript and non-visual components.

	
  
Source mode provides an XML editor with robust code 
completion, syntax highlighting, and error highlighting. The 
figure below shows the MXML editor in source mode with the 
code completion pop-up open.

	
  

Hot 
Tip

ASDoc Tool Tips
You can quickly view the ActionScript documentation as a 
ToolTip in the MXML Source Editor and ActionScript Editor 
by hovering the mouse over a Flex SDK class or method.

http://www.dzone.com
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Each Flex container uses a specific layout to determine the 
size and position of the visual components. The Flex SDK 
provides four general-purpose layouts.  Components can be 
configured using absolute or relative positioning. BasicLayout 
allows absolution positioning, where components are assigned 
specific x and y coordinates. This mode allows pixel level 
control over the appearance of the application. However, it 
also has several drawbacks. When using BasicLayout, users 
cannot (usefully) resize the application.  It can also be very 
difficult to internationalize an application, as buttons and labels 
are often different sizes based on the language. VerticalLayout, 
HorizontalLayout, and TileLayout all provide different 
approaches to layout components using relative positioning.

Name Positioning Description

BasicLayout Absolute Components are positioned using x and y coordinates.

VerticalLayout Relative Components are positioned in a column.

HorizontalLayout Relative Components are positioned in a row.

TileLayout Relative Components are positioned in a grid.

Flex also provides a layout specifically for button bars skins 
(ButtonBarHorizontalLayout).

You can create your own Layouts by extending one of these 
layouts, or their base class, LayoutBase.

ActionScript
When you move beyond simple components and need to 
begin to create object models and complex logic, it is time 
to use the ActionScript editor. The ActionScript editor is a 
traditional source code text editor. 

The editor includes keyword highlighting, error highlighting, 
and provides a list of current problems (Errors and Warning) 
in the view at the bottom of the workspace. The following 
figure shows a simple ActionScript class with two unresolved 
problems.

	
  
Code Completion
Flash Builder provides code completion for many common 
scenarios.  Code completion can be triggered automatically 
based on context or manually, using Ctrl-Space.  Code 
completion is automatically triggered after a period or colon, 
displaying either possible variable and property names, or 
available types. 

Hot 
Tip

Dynamic Methods
ActionScript is a dynamic language.  Therefore, the code 
completion can only provide guidance for the statically 
known functions and properties.  There will be occasions 
when code completion will be unable to identify valid 
functions or properties. 

Code Generation
ActionScript is a relatively concise language, avoiding 
significant amounts of boilerplate code.  However, there are 
still occasions where it is useful to have Flash Builder perform 
common code generation.

Generate Getter/Setter provides the ability to generate a get 
and set method for a given variable.

Generate Event Handler generates an event handler method 
and assigns it to the event property on the MXML component.
Generate Service Call generates code to integrated with server 
classes when using Data Services.

The following table provides a list of where and how these 
code generation functions can be invoked.

Name Location Invoke

Generate 
Getter/Setter

ActionScript Editor Right Click (Win)/Ctrl-Click(OSX) on Variable and 
select Source -> Generate Getter/Setter.

Generate Event 
Handler

MXML Source View, 
MXML Design View

Source: Ctrl-Space in event property.
Design: Right Click on a Component -> Generate 
Click Handler OR click the

 
button in the Flex Properties View and select 
Generate Event Handler.

Generate 
Service Call

MXML Design View Right Click on a Component -> Generate Service 
Call  OR click the 

 
button in the Flex Properties View and select 
Generate Service Call.

Refactoring
Flash Builder provides support for some basic refactoring.  
You can Rename variables and functions, and Rename or 
Move classes using the menu: Source -> Refactor -> Move 

Design mode provides a visual preview of your application. This 
is very useful for laying out the components, or simply checking 
to see how they will look without running the application. The 
Design mode features a list of available components in the 
bottom left window. You can drag and drop these onto your 
application to add them and adjust the layout.

http://www.dzone.com
http://www.refcardz.com
http://www.adobe.com/go/try_flashbuilder
http://ad.doubleclick.net/clk;228228504;52036446;c
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Select the type of service you are using.  You will then be 
taken to the Project Properties page where you can setup your 
service (this the same options and inputs used by the New 
Project Wizard)

BUILDING

	
  
Therefore, it is important to use a valid certificate from a Root 
Certificate Authority when distributing applications to a broad 
user base.

You can also generate an intermediate file (.airi).  This is an 
unsigned .air file that must be signed (and converted to an .air 
file) before it can be distributed.  This is useful in situations 
where the person who builds the project is different from the 
person who is authorized to use the certificate.

RUNNING AND DEBUGGING

Flash Builder provides the ability to launch and debug your 
application from within Flash Builder.  Applications can be 
launched as a separate process (Run), or Flash Builder can 
attach to the running application (Debug).

Flash Builder is configured by default to use your primary mxml 
file as the entry point.  However, you can configure multiple 
Run/Debug configurations using different entry points. 

To run the default application, use the menu Run -> Run main 
(where main is the name of your default mxml file), or use the 
Ctrl-Shift-F11 (Win) or Command-Shift-F11 (OS X) keyboard 
shortcut.  For web applications this will launch your application 
in a browser using the html-template.  Desktop applications 
will be run using Adobe’s runtime engine.

Hot 
Tip

Source Control
Flash Builder supports integration with many different 
source control management tools.  You can install an 
Eclipse Plug-in for the source control management tool 
you use.

Data Centric Development
The Flash Builder Data Centric Development feature allows 
developers to quickly and easily connect Flex applications to a 
backend service.

To use the Data Centric Development feature, the project must 
be connected to a service.  This can either be done when the 
project is created, or later when needed.

If a service was not defined, Flash Builder will prompt to create 
one when the Generate Service Call code generation feature is 
first used.  

(or Rename).  You can also access the Refactor menu from the 
context menu (Right Click (Win) or Ctrl Click (OS X)).  These 
menu items will open a dialog box allowing you to specify the 
new name or location.

Compiling
Flash Builder performs a background compilation every time 
a file is saved.  This provides real time feedback to compile 
errors while also encouraging users to save regularly.  You can 
disable this feature by selecting the menu Project -> Build 
Automatically.  You can perform a manual incremental compile 
at any time using Ctrl-B (Win) or Command-B (OS X).

You can perform a clean compile by selecting the Project -> 
Clean… menu item.  You can then opt to rebuild one or more 
of the projects in your workspace.

Export Release Build
When you are done testing and ready to distribute your 
application, you can use the Export Release Build command 
(Project -> Export Release Build…) to create a packaged 
version of your application.

Web projects are packaged into .swf files that can be 
uploaded to your web server for distribution.  Flash Builder 
also generates an HTML page and supporting files for your 
application.  You can find the template in the html-template 
directory.  This enables easy deployment of an application, or 
can serve as a guide for a custom HTML page.

Desktop projects are packaged into an .air file that can be 
installed on a user’s computer.  Each Adobe AIR application 
must be signed using a digital certificate.  You can purchase 
a certificate from a Root Certificate Authority, or generate 
your own self-signed certificate.  If you generate your own 
certificate, users will receive a warning when they install 
the application.

http://www.dzone.com
http://www.refcardz.com
http://www.adobe.com/go/try_flashbuilder
http://ad.doubleclick.net/clk;228228504;52036446;c
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You can select Remember my decision to automatically switch 
to the Flex Debug perspective in the future.

Breakpoints can be set by clicking to the left of the line 
number in the Editor, or using the menu Run -> Toggle 
Breakpoint or using the keyboard shortcut Ctrl-Shift-B (Win) 
or Command-Shift-B (OS X).  By default the debugger will 
stop before the code on the selected line is executed.  You 
can make a breakpoint conditional by opening the breakpoint 
properties (Right-Click on the Breakpoint and select                    
Breakpoint Properties).

	
  
Select the Enabled checkbox and specify the condition 
that must be true for the breakpoint.  You can also choose 
to specify a value, and the breakpoint will pause when that     
value changes.

	
  
This view provides a convenient way to explore the variables 
that exist within the current scope.  While this is useful, it can 
be time consuming to find a specific value during extended 
debugging sessions or across repeated debugging sessions.  
The Expressions view allows you to set and view the values of 
specific expressions (Watched Expressions).

A Watched Expression is a small code expression that 
produces a single value.  Expressions can be simple variables 
or complex logic including function calls that evaluate to 
a single value.  The following figure shows two watched 
expressions, the first is a variable while the second is a simple 
Boolean statement.

	
  
Network Monitor
Many applications developed with Flash Builder communicate 
with external services to read or write data.  This can be 
difficult to debug without additional visibility into what is 
happening.

Flash Builder includes the Network Monitor view, which 
provides visibility into the network calls made by the program.   
The Network Monitor tracks all requests, including the URL, 
Request and Response Times, Duration, and Operation.  For 
each request, you can inspect the Request and Response using 
a view similar to the Variables view.

Hot 
Tip

Flex Debug Perspective
Remember to use the Flex Debug perspective when 
debugging an application.  Flash Builder will also prompt 
you to switch when a breakpoint is hit during debugging.

If you want to debug the application you can launch it using 
Run -> Debug main, or use the Ctrl-F11 (Win) or Command-F11 
(OS X) keyboard shortcut.  This will launch the application in 
the browser or runtime engine, and Flash Builder will connect 
to the running application, allowing control and introspection.

Breakpoints
When debugging an application, you can set breakpoints to 
indicate you want the application to pause when it reaches a 
certain line.  Flash Builder allows even more control, allowing 
break points that are conditional on the value of variables       
or functions.

Execution Control
Flash Builder allows fine-grained control over the execution 
of each line of code while debugging.  The Flex Debug 
perspective provides a toolbar with buttons to step Into, Over, 
and Out of (Return) the current line.  You can tell Flash Builder 
to run to the current line using the keyboard shortcut Ctrl-R 
(Win) or Command-R (OS X)

Variables and Expressions
While debugging in the Flex Debug perspective, you can view 
the current values for your variables using the Variables view. 

http://www.dzone.com
http://www.refcardz.com
http://www.adobe.com/go/try_flashbuilder
http://ad.doubleclick.net/clk;228228504;52036446;c
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Continuous Integration:

Patterns and Anti-Patterns

CONTENTS INCLUDE:

■ About Continuous Integration

■ Build Software at Every Change

■ Patterns and Anti-patterns

■ Version Control

■ Build Management

■ Build Practices and more...

Continuous Integration (CI) is the process of building software 

with every change committed to a project’s version control 

repository.  

CI can be explained via patterns (i.e., a solution to a problem 

in a particular context) and anti-patterns (i.e., ineffective 

approaches sometimes used to “fi x” the particular problem) 

associated with the process. Anti-patterns are solutions that 

appear to be benefi cial, but, in the end, they tend to produce 

adverse effects. They are not necessarily bad practices, but can 

produce unintended results when compared to implementing 

the pattern.

Continuous Integration

While the conventional use of the term Continuous Integration 

efers to the “build and test” cycle, this Refcard 

expands on the notion of CI to include concepts such as 
 

Aldon®

Change. Collaborate. Comply.

Pattern

Description

Private Workspace
Develop software in a Private Workspace to isolate changes

Repository

Commit all fi les to a version-control repository

Mainline

Develop on a mainline to minimize merging and to manage 

active code lines

Codeline Policy

Developing software within a system that utilizes multiple 

codelines

Task-Level Commit
Organize source code changes by task-oriented units of work 

and submit changes as a Task Level Commit

Label Build

Label the build with unique name

Automated Build

Automate all activities to build software from source without 

manual confi guration

Minimal Dependencies
Reduce pre-installed tool dependencies to the bare minimum

Binary Integrity

For each tagged deployment, use the same deployment 

package (e.g. WAR or EAR) in each target environment

Dependency Management Centralize all dependent libraries

Template Verifi er

Create a single template fi le that all target environment 

properties are based on

Staged Builds

Run remote builds into different target environments

Private Build

Perform a Private Build before committing changes to the 

Repository

Integration Build

Perform an Integration Build periodically, continually, etc.

Send automated feedback from CI server to development team

ors as soon as they occur

Generate developer documentation with builds based on 

brought to you by...
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Core HTMLHTML and XHTML are the foundation of all web development.  

HTML is used as the graphical user interface in client-side 

programs written in JavaScript. Server-side languages like PHP 

and Java also receive data from web pages and use HTML 

as the output mechanism. The emerging Ajax technologies 

likewise use HTML and XHTML as their visual engine. HTML 

was once a very loosely-defi ned language with very little 

standardization, but as it has become more important, the 

need for standards has become more apparent.  Regardless of 

whether you choose to write HTML or XHTML, understanding 

the current standards will help you provide a solid foundation 

that will simplify all your other web coding.  Fortunately HTML 

and XHTML are actually simpler than they used to be, because 

much of the functionality has moved to CSS.

common elements
Every page (HTML or XHTML shares certain elements in

common.)  All are essentially plain text 

extension.  HTML fi les should not be cr

processor

CONTENTS INCLUDE:
■ HTML Basics■ HTML vs XHTML

■ Validation■ Useful Open Source Tools

■ Page Structure Elements
■ Key Structural Elements and more...

The src attribute describes where the image fi le can be found, 

and the alt attribute describes alternate text that is displayed if 

the image is unavailable.Nested tagsTags can be (and frequently are) nested inside each other.  Tags 

cannot overlap, so <a><b></a></b> is not legal, but <a><b></

b></a> is fi ne. 

HTML VS XHTMLHTML has been around for some time. While it has done its 

job admirably, that job has expanded far more than anybody 

expected.  Early HTML had very limited layout support.

Browser manufacturers added many competing standar

web developers came up with clever workar

result is a lack of standar
The latest web standar

Browse our collection of over 100 Free Cheat Sheets
Upcoming Refcardz
Network Security
Hadoop
UML
Subversion
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ABOUT CLOUD COMPUTING
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Getting Started with 
Cloud Computing

CONTENTS INCLUDE:
■ About Cloud Computing
■ Usage Scenarios
■ Underlying Concepts 
■ Cost
■ Data Tier Technologies
■ Platform Management and more...

Web applications have always been deployed on servers 
connected to what is now deemed the ‘cloud’.

However, the demands and technology used on such servers 
has changed substantially in recent years, especially with 
the entrance of service providers like Amazon, Google and 
Microsoft. 

These companies have long deployed web applications 
that adapt and scale to large user bases, making them 
knowledgeable in many aspects related to cloud computing.

This Refcard will introduce to you to cloud computing, with an 
emphasis on these providers, so you can better understand 
what it is a cloud computing platform can offer your web 
applications.

USAGE SCENARIOS

Pay only what you consume
Web application deployment until a few years ago was similar 
to most phone services: plans with alloted resources, with an 
incurred cost whether such resources were consumed or not.

Cloud computing as it’s known today has changed this. 
The various resources consumed by web applications (e.g. 
bandwidth, memory, CPU) are tallied on a per-unit basis 
(starting from zero) by all major cloud computing platforms.

also minimizes the need to make design changes to support 
one time events. 

Automated growth & scalable technologies
Having the capability to support one time events, cloud 
computing platforms also facilitate the gradual growth curves 
faced by web applications.

Large scale growth scenarios involving specialized equipment 
(e.g. load balancers and clusters) are all but abstracted away by 
relying on a cloud computing platform’s technology.

In addition, several cloud computing platforms support data 
tier technologies that exceed the precedent set by Relational 
Database Systems (RDBMS): Map Reduce, web service APIs, 
etc. Some platforms support large scale RDBMS deployments.

CLOUD COMPUTING PLATFORMS AND 
UNDERLYING CONCEPTS

Amazon EC2: Industry standard software and virtualization
Amazon’s cloud computing platform is heavily based on 
industry standard software and virtualization technology.

Virtualization allows a physical piece of hardware to be 
utilized by multiple operating systems. This allows resources 
(e.g. bandwidth, memory, CPU) to be allocated exclusively to 
individual operating system instances.

As a user of Amazon’s EC2 cloud computing platform, you are 
assigned an operating system in the same way as on all hosting 
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FlashBuilder provides the ability to create TestSuite and 
TestCase classes from the menu File -> New -> Test Suite Class 
(or Test Case Class).  These menu items open a Dialog box that 
allows you to specify the options to create the class.

FlashBuilder supports the creation of both FlexUnit 1 and 
FlexUnit 4 code.  After selecting the appropriate package, 
class name, and other parameters, you can select a specific 
class to test, in this case Foo. The next step allows you to 
select individual methods to test.

FlexUnit tests can be run from the menu Run -> Run -> 
FlexUnit Tests.

Try Flash Builder 4: www.adobe.com/go/try_flashbuilder

Eric Daugherty is a Senior Architect at Gorilla 
Logic, Inc. (www.gorillalogic.com) where he develops 
enterprise applications using Flex and Java.  He 
enjoys solving problems and is passionate about 
learning new technologies and tools.  You can read 
about his open source projects and blog at: 

http://www.ericdaugherty.com/blog/

TESTING

Unit Testing is commonly used by development teams to 
provide automated initial and regression testing.  Flex 
developers can use FlexUnit, an open-source testing 
framework modeled after the popular JUnit project used for 
Java Unit Testing.  FlashBuilder supports FlexUnit testing by 
providing integrated code generation and execution features, 
including the ability to create TestSuite and TestCase classes, 
and the Run and Debug tests.

Hot 
Tip

FlexUnit
You can find out more about FlexUnit from the project 
home page: http://opensource.adobe.com/wiki/display/
flexunit/FlexUnit

A FlexUnit test case is an individual method that executes a 
portion of an application and asserts that the results received 
were the expected results.  Test cases are grouped into a 
TestCase class.  TestCase classes are grouped into a TestSuite 
class, allowing groups of test to be organized and run as 
separate suites.  An individual TestCase class could be added 
to multiple TestSuites.

	
  

Flex 4 in Action is an easy-to-follow, hands-on Flex 
4 tutorial. Revised and updated from the previous 
edition on Flex 3, this book is chock-full of examples, 
goes beyond feature coverage, and helps readers 
put Flex to work in real day-to-day tasks. 

BUY NOW
books.dzone.com/books/flex4
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